Salt Water Chlorine Generators, Ozone, UV

SWGs, salt water chlorine generators, chlorinators,
ozone generators, UV systems, . . .
  • Topics
    Replies
    Views
    Last post
  • not producing chlorine
    by stressed but happy » Sun 06 Sep, 2009 21:47
    4 Replies
    2470 Views
    Last post by stressed but happy
    Sat 12 Sep, 2009 20:39
  • Chlorine Allergy-Tests confirmed-help
    by suz155 » Sat 05 Sep, 2009 11:44
    4 Replies
    4457 Views
    Last post by suz155
    Mon 07 Sep, 2009 21:47
  • How to Choose a Salt Generator
    by JerKaz » Thu 27 Aug, 2009 20:32
    3 Replies
    1530 Views
    Last post by Me...
    Sat 29 Aug, 2009 09:20
  • Help! New aqua rite - how to test cell?
    by GLEN E » Sat 11 Jul, 2009 17:02
    3 Replies
    2188 Views
    Last post by thepoolyoda
    Mon 24 Aug, 2009 17:09
  • well water iron bad for saltwater generator?
    by zash008 » Fri 03 Jul, 2009 17:44
    1 Replies
    728 Views
    Last post by thepoolyoda
    Mon 24 Aug, 2009 16:51
  • Aqua Rite not working
    by peb721 » Fri 14 Aug, 2009 19:59
    0 Replies
    591 Views
    Last post by peb721
    Fri 14 Aug, 2009 19:59
  • Error code 194 - did anyone find out what is means?
    by MichaelinFrance » Fri 07 Aug, 2009 08:50
    0 Replies
    557 Views
    Last post by MichaelinFrance
    Fri 07 Aug, 2009 08:50
  • New member with high temp water
    by suz155 » Sat 18 Jul, 2009 11:20
    2 Replies
    972 Views
    Last post by Roy Berry
    Thu 30 Jul, 2009 11:11
  • Aqua Trol HP Salt Reading
    by Conehead396 » Thu 23 Jul, 2009 20:13
    0 Replies
    980 Views
    Last post by Conehead396
    Thu 23 Jul, 2009 20:13
  • Aquarite - No Display - 4 Flashing Lights - Fuse Ok
    by gadgetfl » Sat 11 Apr, 2009 19:44
    3 Replies
    2337 Views
    Last post by BEGINNER
    Tue 21 Jul, 2009 12:26
  • AquaRite, low salt and check cell on
    by PCBeach » Mon 13 Jul, 2009 17:35
    3 Replies
    2407 Views
    Last post by PCBeach
    Sat 18 Jul, 2009 16:44
  • Aquarite "No Flow" fixed - now cloudy water
    by m1k2s3 » Tue 14 Jul, 2009 19:02
    0 Replies
    807 Views
    Last post by m1k2s3
    Tue 14 Jul, 2009 19:02
  • High salt
    by saling4 » Sat 04 Jul, 2009 14:31
    0 Replies
    629 Views
    Last post by saling4
    Sat 04 Jul, 2009 14:31
  • Aquarite cell showing "no flow'
    by socaldoc » Sun 28 Jun, 2009 15:02
    0 Replies
    659 Views
    Last post by socaldoc
    Sun 28 Jun, 2009 15:02
  • Effect of high Ph level on Aquarite cell?
    by johnd13 » Fri 26 Jun, 2009 18:46
    1 Replies
    665 Views
    Last post by chem geek
    Sat 27 Jun, 2009 15:38
  • Does salt in pool cause water to be cloudy?
    by 737mech » Sat 20 Jan, 2007 20:47
    11 Replies
    16239 Views
    Last post by Alabama pool guy
    Tue 23 Jun, 2009 11:35
  • PS-16 Aqua Logic
    by Wally » Tue 30 Sep, 2008 22:45
    1 Replies
    1087 Views
    Last post by PoolJerk
    Thu 18 Jun, 2009 20:51
  • Need Help Please
    by losingmytan » Thu 18 Jun, 2009 11:26
    1 Replies
    948 Views
    Last post by chem geek
    Thu 18 Jun, 2009 12:03
  • Chlorine generator question (Electric bill)
    by KenBob » Tue 16 Jun, 2009 22:02
    0 Replies
    680 Views
    Last post by KenBob
    Tue 16 Jun, 2009 22:02
  • ORP & Ph sensing plumbing question
    by Rick Sass » Sat 13 Jun, 2009 07:50
    5 Replies
    2395 Views
    Last post by Me...
    Mon 15 Jun, 2009 08:16

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests