Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Extremely Neglected In-Ground Pool
    Attachment(s) by Soozeeq89 » Sat 22 Jun, 2019 23:46
    4 Replies
    34 Views
    Last post by Teapot
    Tue 25 Jun, 2019 16:40
  • Pump motor cycling on and off
    by bucketofish » Fri 21 Jun, 2019 16:53
    5 Replies
    39 Views
    Last post by Teapot
    Sun 23 Jun, 2019 23:22
  • Sta rite on a pump 462e 0.3hp has died
    by kieronma » Fri 21 Jun, 2019 15:08
    0 Replies
    18 Views
    Last post by kieronma
    Fri 21 Jun, 2019 15:08
  • Unsure what these are for
    Attachment(s) by arizona_pool » Thu 20 Jun, 2019 19:28
    1 Replies
    15 Views
    Last post by Teapot
    Thu 20 Jun, 2019 23:22
  • Drain Cap for an unknown Top Mount Sand Filter
    Attachment(s) by Jackiboy » Tue 18 Jun, 2019 11:49
    11 Replies
    71 Views
    Last post by Denniswiseman
    Thu 20 Jun, 2019 11:42
  • Pipe connections not fitting correctly
    by wstalcup » Tue 18 Jun, 2019 15:41
    2 Replies
    23 Views
    Last post by Denniswiseman
    Wed 19 Jun, 2019 03:01
  • Great water pressure without cartridge, none with cartridge
    by dschddny » Mon 17 Jun, 2019 16:44
    5 Replies
    51 Views
    Last post by Teapot
    Tue 18 Jun, 2019 10:30
  • Low Pressure
    by Newbie » Mon 03 Apr, 2006 17:36
    97 Replies
    203762 Views
    Last post by Teapot
    Tue 18 Jun, 2019 10:26
  • Barbed fittings grrrr
    by Trsix » Thu 13 Jun, 2019 19:17
    1 Replies
    33 Views
    Last post by Trsix
    Sun 16 Jun, 2019 08:34
  • High pressure, low return
    by Dragonlibrarian » Sun 09 Jun, 2019 21:10
    4 Replies
    94 Views
    Last post by Teapot
    Mon 10 Jun, 2019 00:22
  • Pump/Filter On/Off During Pool Use?
    by TabSinger2 » Mon 21 Jun, 2010 23:05
    6 Replies
    20530 Views
    Last post by Teapot
    Sat 08 Jun, 2019 14:54
  • No main drain valve
    Attachment(s) by juvefc » Fri 07 Jun, 2019 18:50
    1 Replies
    36 Views
    Last post by Teapot
    Sat 08 Jun, 2019 07:07
  • DIY Solar Heater Plumbing Advice
    Attachment(s) by Sprinkles » Thu 06 Jun, 2019 21:11
    0 Replies
    33 Views
    Last post by Sprinkles
    Thu 06 Jun, 2019 21:11
  • How to run the pool in "normal" everyday use?
    Attachment(s) by rkick07 » Thu 06 Jun, 2019 14:06
    2 Replies
    70 Views
    Last post by rkick07
    Thu 06 Jun, 2019 18:21
  • Pump outlet connection persistent leaking very slowly
    by miamicuse » Wed 29 May, 2019 09:06
    8 Replies
    109 Views
    Last post by Teapot
    Wed 05 Jun, 2019 09:16
  • Filter
    by CapriKrissy » Tue 04 Jun, 2019 07:52
    10 Replies
    164 Views
    Last post by Denniswiseman
    Wed 05 Jun, 2019 04:01
  • Pentair booster pump no power
    by Lis530 » Tue 04 Jun, 2019 15:15
    1 Replies
    42 Views
    Last post by Teapot
    Tue 04 Jun, 2019 15:43
  • Sand in bottom of pool and whistling sound from filter
    by Jess3311 » Wed 22 May, 2019 09:11
    11 Replies
    138 Views
    Last post by Teapot
    Sun 02 Jun, 2019 16:30
  • Hayward 714 T mutiport problem
    by mikhett » Wed 29 May, 2019 15:57
    1 Replies
    32 Views
    Last post by Teapot
    Thu 30 May, 2019 09:13
  • Pump sitting on concrete blocks
    by miamicuse » Wed 29 May, 2019 21:52
    0 Replies
    38 Views
    Last post by miamicuse
    Wed 29 May, 2019 21:52

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 2 guests