Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Broken backwash slide valve
    by gurnman » Tue 01 Oct, 2013 20:24
    6 Replies
    2984 Views
    Last post by CGPoolman
    Fri 04 Oct, 2013 08:38
  • Replacing SP-1408 Return Fitting, Vinyl Liner IG-Advice/Tips
    by KenB » Mon 30 Sep, 2013 07:46
    0 Replies
    906 Views
    Last post by KenB
    Mon 30 Sep, 2013 07:46
  • Solar Plumbing - mine looks strange?
    Attachment(s) by Karl72 » Wed 11 Sep, 2013 07:23
    3 Replies
    5304 Views
    Last post by Free info
    Sat 21 Sep, 2013 10:41
  • Reconnecting pipes to new pump
    by bobds » Sun 08 Sep, 2013 14:02
    2 Replies
    874 Views
    Last post by bobds
    Sun 08 Sep, 2013 17:31
  • EcoStar VSP and 1.5 inch piping
    by sailor21 » Sat 17 Aug, 2013 06:37
    4 Replies
    2176 Views
    Last post by mas985
    Thu 22 Aug, 2013 13:21
  • Sta-rite pump leaking water out the back!
    by tjmoneypit1 » Tue 20 Aug, 2013 16:08
    1 Replies
    1208 Views
    Last post by CGPoolman
    Wed 21 Aug, 2013 06:23
  • Low pressure in filter hosing
    by baja bob » Wed 14 Aug, 2013 17:13
    0 Replies
    495 Views
    Last post by baja bob
    Wed 14 Aug, 2013 17:13
  • Leaking fitting - caulk or replace
    Attachment(s) by Cygnusx197 » Mon 12 Aug, 2013 19:55
    1 Replies
    949 Views
    Last post by CGPoolman
    Wed 14 Aug, 2013 07:07
  • No Vaccum Side
    by tbone » Tue 30 Jul, 2013 09:58
    2 Replies
    1050 Views
    Last post by tbone
    Sat 10 Aug, 2013 08:38
  • Wiring entrance - what is the name of that part ?
    by littlejohn » Wed 07 Aug, 2013 07:46
    2 Replies
    790 Views
    Last post by CGPoolman
    Thu 08 Aug, 2013 07:14
  • Pentair pump wiring Line 1 Line 2?
    by SuperD » Sat 30 May, 2009 13:30
    15 Replies
    26243 Views
    Last post by pm80rs
    Sun 04 Aug, 2013 13:12
  • System pressure help
    by sebasendallas » Thu 01 Aug, 2013 22:58
    0 Replies
    482 Views
    Last post by sebasendallas
    Thu 01 Aug, 2013 22:58
  • Cant clear my pool
    by bella81762 » Sat 20 Jul, 2013 18:35
    0 Replies
    540 Views
    Last post by bella81762
    Sat 20 Jul, 2013 18:35
  • Auto-Chlorinator problem
    by Stumped » Thu 11 Jul, 2013 19:23
    1 Replies
    906 Views
    Last post by CGPoolman
    Fri 12 Jul, 2013 13:48
  • Jacuzzi 160L sand filter Leak
    by Amyk252213247 » Tue 09 Jul, 2013 16:23
    0 Replies
    371 Views
    Last post by Amyk252213247
    Tue 09 Jul, 2013 16:23
  • Help
    by inshore dave » Sun 07 Jul, 2013 08:35
    0 Replies
    401 Views
    Last post by inshore dave
    Sun 07 Jul, 2013 08:35
  • Possible filter issue with air
    by rbf351 » Tue 02 Jul, 2013 13:49
    9 Replies
    3741 Views
    Last post by rbf351
    Sat 06 Jul, 2013 08:10
  • Stripped threads for polaris hookup
    by tored1971 » Sun 30 Jun, 2013 10:57
    2 Replies
    1567 Views
    Last post by tored1971
    Tue 02 Jul, 2013 16:26
  • Won't Prime -- Bubbles in Hose
    by wwwursaaa » Sun 23 Jun, 2013 09:26
    0 Replies
    370 Views
    Last post by wwwursaaa
    Sun 23 Jun, 2013 09:26
  • Pump works, but not when hooked up to the filter
    by Dolydmpls » Mon 17 Jun, 2013 20:02
    0 Replies
    339 Views
    Last post by Dolydmpls
    Mon 17 Jun, 2013 20:02

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 1 guest