Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Hayward flow sensor help
    by shadowmelt » Mon 18 Jul, 2016 00:42
    1 Replies
    158 Views
    Last post by Denniswiseman
    Mon 18 Jul, 2016 03:24
  • HAYWARD PUMP "Drive Error" "Pump has Stalled"
    by Swimsos » Fri 15 Jul, 2016 17:02
    0 Replies
    634 Views
    Last post by Swimsos
    Fri 15 Jul, 2016 17:02
  • Pool pipe fixture
    by alexmm » Tue 12 Jul, 2016 19:00
    0 Replies
    113 Views
    Last post by alexmm
    Tue 12 Jul, 2016 19:00
  • Need help on where to plumb in a water line to supply slide
    by shenard » Mon 11 Jul, 2016 17:47
    1 Replies
    145 Views
    Last post by Denniswiseman
    Tue 12 Jul, 2016 02:59
  • Restore and excavate a pool?
    Attachment(s) by LilChicka » Thu 07 Jul, 2016 21:40
    5 Replies
    244 Views
    Last post by Denniswiseman
    Tue 12 Jul, 2016 02:43
  • 3THP pump and 72 sq DE filter?
    by pepo289 » Sat 09 Jul, 2016 13:57
    0 Replies
    111 Views
    Last post by pepo289
    Sat 09 Jul, 2016 13:57
  • Recovering a filled in pool, worth it?
    by LilChicka » Thu 07 Jul, 2016 21:30
    0 Replies
    120 Views
    Last post by LilChicka
    Thu 07 Jul, 2016 21:30
  • Loud Pool Pump? Something wrong??
    by PoolNovice007 » Fri 01 Jul, 2016 18:01
    1 Replies
    166 Views
    Last post by Denniswiseman
    Sun 03 Jul, 2016 03:33
  • Motor overheats
    by Lynsay » Fri 01 Jul, 2016 15:52
    0 Replies
    127 Views
    Last post by Lynsay
    Fri 01 Jul, 2016 15:52
  • How to turn on linux pool filter?
    by branden15 » Mon 27 Jun, 2016 18:57
    1 Replies
    109 Views
    Last post by Denniswiseman
    Wed 29 Jun, 2016 11:10
  • Pre and post Sand Change, still losing water flow
    by paksoyk » Thu 23 Jun, 2016 11:24
    1 Replies
    126 Views
    Last post by Denniswiseman
    Sun 26 Jun, 2016 10:14
  • Aqualoon media
    by TheRealJRogers » Thu 14 Apr, 2016 20:39
    1 Replies
    1573 Views
    Last post by hydrofool
    Sat 18 Jun, 2016 15:53
  • Pump Pipes Leaking after new pump installation
    Attachment(s) by rbdeli » Mon 06 Jun, 2016 18:41
    2 Replies
    235 Views
    Last post by Denniswiseman
    Wed 15 Jun, 2016 11:55
  • Solenoid Vavle v. an Auto Fill?
    by gpowers » Thu 19 Jul, 2012 09:38
    4 Replies
    3384 Views
    Last post by poolmandave33
    Tue 14 Jun, 2016 11:30
  • Main Pool Suctions will not Circulate
    by Floyd341 » Sun 12 Jun, 2016 21:40
    0 Replies
    121 Views
    Last post by Floyd341
    Sun 12 Jun, 2016 21:40
  • Sand in glass jar on backwash
    by squbbles » Mon 06 Jun, 2016 12:25
    0 Replies
    269 Views
    Last post by squbbles
    Mon 06 Jun, 2016 12:25
  • Pump won't prime and surges
    by clubcariker » Thu 05 May, 2016 10:33
    3 Replies
    1013 Views
    Last post by mas985
    Thu 26 May, 2016 16:53
  • Water slowly draining from pump after backwash....
    by Pmack963 » Wed 04 May, 2016 18:46
    2 Replies
    483 Views
    Last post by Denniswiseman
    Tue 24 May, 2016 03:55
  • Sand Filter Not Working
    by havl » Thu 28 Apr, 2016 11:14
    2 Replies
    313 Views
    Last post by BobbyKilo
    Sun 08 May, 2016 21:05
  • Loosing Presure
    by Dewald » Thu 14 Apr, 2016 04:39
    11 Replies
    323 Views
    Last post by Dewald
    Wed 20 Apr, 2016 09:14

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 5 guests