Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • System pressure help
    by sebasendallas » Thu 01 Aug, 2013 22:58
    0 Replies
    484 Views
    Last post by sebasendallas
    Thu 01 Aug, 2013 22:58
  • Cant clear my pool
    by bella81762 » Sat 20 Jul, 2013 18:35
    0 Replies
    544 Views
    Last post by bella81762
    Sat 20 Jul, 2013 18:35
  • Auto-Chlorinator problem
    by Stumped » Thu 11 Jul, 2013 19:23
    1 Replies
    913 Views
    Last post by CGPoolman
    Fri 12 Jul, 2013 13:48
  • Jacuzzi 160L sand filter Leak
    by Amyk252213247 » Tue 09 Jul, 2013 16:23
    0 Replies
    373 Views
    Last post by Amyk252213247
    Tue 09 Jul, 2013 16:23
  • Help
    by inshore dave » Sun 07 Jul, 2013 08:35
    0 Replies
    401 Views
    Last post by inshore dave
    Sun 07 Jul, 2013 08:35
  • Possible filter issue with air
    by rbf351 » Tue 02 Jul, 2013 13:49
    9 Replies
    4135 Views
    Last post by rbf351
    Sat 06 Jul, 2013 08:10
  • Stripped threads for polaris hookup
    by tored1971 » Sun 30 Jun, 2013 10:57
    2 Replies
    1681 Views
    Last post by tored1971
    Tue 02 Jul, 2013 16:26
  • Won't Prime -- Bubbles in Hose
    by wwwursaaa » Sun 23 Jun, 2013 09:26
    0 Replies
    372 Views
    Last post by wwwursaaa
    Sun 23 Jun, 2013 09:26
  • Pump works, but not when hooked up to the filter
    by Dolydmpls » Mon 17 Jun, 2013 20:02
    0 Replies
    340 Views
    Last post by Dolydmpls
    Mon 17 Jun, 2013 20:02
  • Pump overheating
    by Holzer » Tue 22 May, 2007 02:08
    31 Replies
    51304 Views
    Last post by graystone
    Thu 13 Jun, 2013 21:19
  • Calculating Flow Rate From PSI Reading?
    by flyboy320 » Wed 26 Aug, 2009 20:02
    3 Replies
    7147 Views
    Last post by Jphilip
    Thu 13 Jun, 2013 08:49
  • Polaris Booster Pump
    by chakazullo » Tue 11 Jun, 2013 14:46
    0 Replies
    401 Views
    Last post by chakazullo
    Tue 11 Jun, 2013 14:46
  • Pool losing pressure
    by kelleyruger » Fri 07 Jun, 2013 05:52
    0 Replies
    366 Views
    Last post by kelleyruger
    Fri 07 Jun, 2013 05:52
  • HELP! Sand in the pool
    by Crewey » Tue 07 May, 2013 13:34
    13 Replies
    5394 Views
    Last post by Crewey
    Fri 07 Jun, 2013 01:33
  • Help appreciated. Pump runs fine until hose attached.
    by benspot » Thu 06 Jun, 2013 20:46
    0 Replies
    284 Views
    Last post by benspot
    Thu 06 Jun, 2013 20:46
  • Pumps
    by kojo » Sat 01 Jun, 2013 23:10
    2 Replies
    836 Views
    Last post by kojo
    Sun 02 Jun, 2013 23:07
  • Solar Panels
    by Guest » Wed 29 May, 2013 17:46
    0 Replies
    451 Views
    Last post by Guest
    Wed 29 May, 2013 17:46
  • Air pressure explosion
    by Sally » Wed 15 May, 2013 13:58
    3 Replies
    2226 Views
    Last post by Sally
    Tue 21 May, 2013 10:06
  • Pump won't stay primed, pipes making a whooshing noise
    by allilo » Tue 21 May, 2013 09:06
    0 Replies
    1148 Views
    Last post by allilo
    Tue 21 May, 2013 09:06
  • Broken Backwash Piston
    by IAMFOODMAN » Sat 18 May, 2013 09:24
    1 Replies
    588 Views
    Last post by CGPoolman
    Sun 19 May, 2013 07:40

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests