Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Excessive backwashes
    by dhillg51 » Fri 18 May, 2012 04:49
    0 Replies
    385 Views
    Last post by dhillg51
    Fri 18 May, 2012 04:49
  • Pentair 1 HP pump won't start usually
    by jeffreywilens » Tue 15 May, 2012 23:26
    0 Replies
    479 Views
    Last post by jeffreywilens
    Tue 15 May, 2012 23:26
  • Spa and pump water is draining when the power is off
    by spldbrt » Mon 14 May, 2012 18:18
    1 Replies
    898 Views
    Last post by CGPoolman
    Tue 15 May, 2012 11:25
  • New pump motor running very hot, shutting off
    by CGPoolman » Sat 28 Apr, 2012 18:08
    9 Replies
    13293 Views
    Last post by CGPoolman
    Sun 06 May, 2012 14:07
  • Air in system with pressure loss
    by bkruz » Sat 28 Apr, 2012 08:09
    4 Replies
    1238 Views
    Last post by mas985
    Thu 03 May, 2012 18:53
  • Pentair EC90 DE filter
    by dle5319 » Tue 10 Apr, 2012 04:25
    1 Replies
    733 Views
    Last post by BudgetPoolCare
    Sat 21 Apr, 2012 06:22
  • Using pond water and rainwater to fill a pool
    by ukpoolquestions » Mon 16 Apr, 2012 05:59
    1 Replies
    1788 Views
    Last post by BudgetPoolCare
    Sat 21 Apr, 2012 06:06
  • Sand coming out return jets
    by 360Lover » Sun 25 Mar, 2012 13:16
    3 Replies
    5743 Views
    Last post by scg
    Fri 20 Apr, 2012 08:35
  • Pentair filter major problem
    by Tahoe » Tue 10 Apr, 2012 05:58
    1 Replies
    881 Views
    Last post by mred
    Thu 19 Apr, 2012 14:35
  • Skimmer lid blows off when pump shuts off
    by harleyd » Tue 27 May, 2008 15:52
    3 Replies
    2566 Views
    Last post by Drama pool
    Sun 08 Apr, 2012 20:41
  • Low Presure and reduce water flow
    by pjogopulos » Thu 05 Apr, 2012 15:06
    1 Replies
    1252 Views
    Last post by mas985
    Sun 08 Apr, 2012 18:04
  • Hayward Filter Clamp Spring Assembly Replacement Kit
    by thepurplem0nkey » Thu 05 Apr, 2012 13:04
    1 Replies
    3275 Views
    Last post by TSH Tech
    Fri 06 Apr, 2012 03:28
  • New pump motor problem
    by NCKevin » Sat 31 Mar, 2012 13:04
    1 Replies
    616 Views
    Last post by Göran
    Tue 03 Apr, 2012 11:48
  • Above Ground Intex Pool
    by alarm_guy1 » Sun 01 Apr, 2012 13:04
    2 Replies
    1422 Views
    Last post by alarm_guy1
    Mon 02 Apr, 2012 14:52
  • New pump motor broblem
    by NCKevin » Sat 31 Mar, 2012 13:01
    0 Replies
    301 Views
    Last post by NCKevin
    Sat 31 Mar, 2012 13:01
  • Sand filter and pump lid leaking
    by arthurday » Sat 24 Mar, 2012 11:12
    1 Replies
    1143 Views
    Last post by HomeSydney
    Fri 30 Mar, 2012 02:30
  • Baqua Pure Sand Filter Issues..Please HELP!!
    by michele » Tue 19 May, 2009 19:47
    5 Replies
    3964 Views
    Last post by J.L.lane
    Thu 29 Mar, 2012 08:12
  • Pump is hot to touch
    by valroper » Sun 25 Mar, 2012 09:43
    1 Replies
    758 Views
    Last post by czechmate
    Sun 25 Mar, 2012 10:24
  • Strange pump motor problem
    by JohnSWA » Mon 28 Dec, 2009 12:03
    16 Replies
    8066 Views
    Last post by czechmate
    Fri 16 Mar, 2012 19:32
  • Water Heater
    by aft » Mon 20 Feb, 2012 15:01
    2 Replies
    605 Views
    Last post by IndoorPoolGuy
    Sat 10 Mar, 2012 20:38

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot], Tweetmeme [Bot] and 2 guests