Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Pump looses prime
    by Dave » Tue 21 Mar, 2006 08:20
    6 Replies
    17243 Views
    Last post by Dave P
    Tue 14 Jun, 2011 11:38
  • Sand filter
    by amanda1234 » Mon 13 Jun, 2011 22:47
    0 Replies
    284 Views
    Last post by amanda1234
    Mon 13 Jun, 2011 22:47
  • Intelliflo VS or Whisperflow?
    by topshelf » Sat 11 Jun, 2011 23:41
    0 Replies
    282 Views
    Last post by topshelf
    Sat 11 Jun, 2011 23:41
  • Bubbles in Pump basket/intake area - Hayward Super Pump 1HP
    by LordX2 » Sat 11 Jun, 2011 19:11
    0 Replies
    557 Views
    Last post by LordX2
    Sat 11 Jun, 2011 19:11
  • Pump Prime - getting it back
    by Jynxus » Sat 11 Jun, 2011 09:36
    2 Replies
    792 Views
    Last post by czechmate
    Sat 11 Jun, 2011 18:55
  • Spa Jets and Pump Problems
    by blakeruff » Thu 09 Jun, 2011 23:15
    1 Replies
    979 Views
    Last post by mas985
    Sat 11 Jun, 2011 11:58
  • Air in filter-was Dad wrong?
    by ellieirish » Fri 10 Jun, 2011 18:21
    1 Replies
    594 Views
    Last post by mas985
    Sat 11 Jun, 2011 11:56
  • Return jet placement
    by stroker » Sat 11 Jun, 2011 10:32
    0 Replies
    1397 Views
    Last post by stroker
    Sat 11 Jun, 2011 10:32
  • Physics question
    by navigator11111 » Wed 08 Jun, 2011 18:38
    2 Replies
    565 Views
    Last post by czechmate
    Thu 09 Jun, 2011 07:57
  • Return hose
    by garrison1979 » Mon 06 Jun, 2011 19:12
    0 Replies
    566 Views
    Last post by garrison1979
    Mon 06 Jun, 2011 19:12
  • Leak with Filter (Baquapure)
    by jmdesign404 » Mon 06 Jun, 2011 14:15
    0 Replies
    464 Views
    Last post by jmdesign404
    Mon 06 Jun, 2011 14:15
  • Water escaping through backwash hose
    by irishsph » Sat 04 Jun, 2011 11:52
    0 Replies
    409 Views
    Last post by irishsph
    Sat 04 Jun, 2011 11:52
  • Multiport valve labels?
    Attachment(s) by Rob7477 » Tue 24 Mar, 2009 18:57
    5 Replies
    12369 Views
    Last post by Larry
    Sat 04 Jun, 2011 05:52
  • Need A Quick Suggestion On How To Remove Old O-Rings
    by coollx » Sun 29 May, 2011 18:17
    1 Replies
    602 Views
    Last post by coollx
    Tue 31 May, 2011 16:26
  • Air in return lines on startup
    by jlate » Mon 23 May, 2011 15:16
    0 Replies
    528 Views
    Last post by jlate
    Mon 23 May, 2011 15:16
  • Setting up elecrical wiring for pool pump? (Pictures inside)
    by Nallows » Sun 22 May, 2011 16:16
    1 Replies
    998 Views
    Last post by czechmate
    Sun 22 May, 2011 18:41
  • Low Pressure at Jets
    by Hayward » Wed 16 May, 2007 20:39
    9 Replies
    17114 Views
    Last post by fairthorne
    Sat 21 May, 2011 18:42
  • American Products Pump Problem
    by GPpoolGuy » Thu 19 May, 2011 11:11
    0 Replies
    278 Views
    Last post by GPpoolGuy
    Thu 19 May, 2011 11:11
  • Waterways Crystal Clear Leak
    by dmc123 » Sun 08 May, 2011 20:05
    1 Replies
    436 Views
    Last post by jenniferhoops
    Thu 19 May, 2011 06:34
  • Flow slow down
    by fina44 » Sun 15 May, 2011 06:44
    2 Replies
    2083 Views
    Last post by czechmate
    Wed 18 May, 2011 18:03

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 1 guest