Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Low Pressure
    by Newbie » Mon 03 Apr, 2006 17:36
    92 Replies
    188161 Views
    Last post by Bundulla
    Wed 06 Jul, 2016 01:40
  • Loud Pool Pump? Something wrong??
    by PoolNovice007 » Fri 01 Jul, 2016 18:01
    1 Replies
    55 Views
    Last post by Denniswiseman
    Sun 03 Jul, 2016 03:33
  • Motor overheats
    by Lynsay » Fri 01 Jul, 2016 15:52
    0 Replies
    46 Views
    Last post by Lynsay
    Fri 01 Jul, 2016 15:52
  • How to turn on linux pool filter?
    by branden15 » Mon 27 Jun, 2016 18:57
    1 Replies
    41 Views
    Last post by Denniswiseman
    Wed 29 Jun, 2016 11:10
  • Pre and post Sand Change, still losing water flow
    by paksoyk » Thu 23 Jun, 2016 11:24
    1 Replies
    42 Views
    Last post by Denniswiseman
    Sun 26 Jun, 2016 10:14
  • Aqualoon media
    by TheRealJRogers » Thu 14 Apr, 2016 20:39
    1 Replies
    678 Views
    Last post by hydrofool
    Sat 18 Jun, 2016 15:53
  • Pump Pipes Leaking after new pump installation
    Attachment(s) by rbdeli » Mon 06 Jun, 2016 18:41
    2 Replies
    108 Views
    Last post by Denniswiseman
    Wed 15 Jun, 2016 11:55
  • Solenoid Vavle v. an Auto Fill?
    by gpowers » Thu 19 Jul, 2012 09:38
    4 Replies
    3071 Views
    Last post by poolmandave33
    Tue 14 Jun, 2016 11:30
  • Main Pool Suctions will not Circulate
    by Floyd341 » Sun 12 Jun, 2016 21:40
    0 Replies
    50 Views
    Last post by Floyd341
    Sun 12 Jun, 2016 21:40
  • Sand in glass jar on backwash
    by squbbles » Mon 06 Jun, 2016 12:25
    0 Replies
    59 Views
    Last post by squbbles
    Mon 06 Jun, 2016 12:25
  • Pump won't prime and surges
    by clubcariker » Thu 05 May, 2016 10:33
    3 Replies
    277 Views
    Last post by mas985
    Thu 26 May, 2016 16:53
  • Water slowly draining from pump after backwash....
    by Pmack963 » Wed 04 May, 2016 18:46
    2 Replies
    167 Views
    Last post by Denniswiseman
    Tue 24 May, 2016 03:55
  • EcoStar SVRS "Drive Error!" Autoprime Failure
    by TSH Tech » Sat 26 May, 2012 18:28
    31 Replies
    19804 Views
    Last post by bcwillason
    Wed 11 May, 2016 21:22
  • Sand Filter Not Working
    by havl » Thu 28 Apr, 2016 11:14
    2 Replies
    166 Views
    Last post by BobbyKilo
    Sun 08 May, 2016 21:05
  • Loosing Presure
    by Dewald » Thu 14 Apr, 2016 04:39
    11 Replies
    173 Views
    Last post by Dewald
    Wed 20 Apr, 2016 09:14
  • PVC Pipe Cutting
    by stonerushpilot » Mon 18 Apr, 2016 18:41
    0 Replies
    70 Views
    Last post by stonerushpilot
    Mon 18 Apr, 2016 18:41
  • Pool plumbing
    by vander » Mon 18 Apr, 2016 09:24
    0 Replies
    70 Views
    Last post by vander
    Mon 18 Apr, 2016 09:24
  • Lost presure in skimmer
    by ebausewein » Sat 16 Apr, 2016 12:43
    2 Replies
    72 Views
    Last post by Denniswiseman
    Mon 18 Apr, 2016 04:56
  • no pressure no water movement
    by seren429 » Fri 08 Apr, 2016 14:18
    1 Replies
    149 Views
    Last post by Denniswiseman
    Sun 10 Apr, 2016 06:43
  • check valve help
    by rodnie74 » Sat 02 Apr, 2016 09:39
    0 Replies
    56 Views
    Last post by rodnie74
    Sat 02 Apr, 2016 09:39

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 3 guests