Pool Pumps, Filters, Plumbing & Piping

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
  • Topics
    Replies
    Views
    Last post
  • Need new pump suggestions - 2nd motor gone in 3 years
    by Guest » Sun 05 Apr, 2009 23:35
    3 Replies
    1850 Views
    Last post by Aquaclear-NZ
    Sat 11 Apr, 2009 23:51
  • Pine Needles in the Northwest...arghhhh
    by Chris007 » Wed 08 Apr, 2009 11:58
    2 Replies
    1776 Views
    Last post by Chris007
    Thu 09 Apr, 2009 11:45
  • Good vacumm but lost presure to jets and water features
    by kevin w » Fri 06 Mar, 2009 22:25
    4 Replies
    3508 Views
    Last post by mgud
    Sun 05 Apr, 2009 14:55
  • Replaced pump, problems
    by unix4me » Sat 04 Apr, 2009 19:50
    2 Replies
    712 Views
    Last post by unix4me
    Sun 05 Apr, 2009 13:40
  • Sand filter
    by Guest » Sat 04 Apr, 2009 21:43
    1 Replies
    579 Views
    Last post by Me...
    Sun 05 Apr, 2009 09:57
  • Out of ideas!
    by westwing » Sat 04 Apr, 2009 16:30
    1 Replies
    625 Views
    Last post by Me...
    Sun 05 Apr, 2009 09:52
  • No water pump pressure, what is broken?
    by activationlink » Sun 08 Mar, 2009 23:57
    4 Replies
    1845 Views
    Last post by activationlink
    Sun 05 Apr, 2009 05:33
  • Possible Low Performing Pump
    by jim1504 » Mon 30 Mar, 2009 06:46
    5 Replies
    1570 Views
    Last post by jim1504
    Thu 02 Apr, 2009 06:50
  • Poor suction, bubbles coming from returns (newbie)
    by louc » Wed 01 Apr, 2009 14:40
    1 Replies
    2490 Views
    Last post by Guest
    Thu 02 Apr, 2009 00:31
  • Filter Lines Will Not Stay On Please Help!!
    by hbk4041 » Sun 03 Aug, 2008 08:52
    5 Replies
    1830 Views
    Last post by Janmar
    Wed 01 Apr, 2009 19:11
  • Pump took a crap
    by davidadavila » Mon 30 Mar, 2009 20:19
    1 Replies
    546 Views
    Last post by Guest
    Wed 01 Apr, 2009 16:39
  • Filter question
    by featherless » Wed 11 Mar, 2009 15:51
    16 Replies
    13080 Views
    Last post by chem geek
    Wed 01 Apr, 2009 11:04
  • pump shutting off
    by lalo » Sun 25 May, 2008 16:30
    1 Replies
    787 Views
    Last post by davidadavila
    Mon 30 Mar, 2009 20:43
  • Pump loses prime at shut off
    by chaotic1 » Wed 25 Mar, 2009 14:51
    3 Replies
    5500 Views
    Last post by Ray1031
    Sat 28 Mar, 2009 14:57
  • DE to Sand and then YUK!
    by poobs » Sun 08 Mar, 2009 10:44
    15 Replies
    4453 Views
    Last post by poobs
    Fri 27 Mar, 2009 22:11
  • Pump motor froze ,,,,,I think,,,,,
    by BigLeefromSC » Fri 20 Mar, 2009 13:15
    3 Replies
    1906 Views
    Last post by Guest
    Fri 27 Mar, 2009 00:37
  • Trying to clean my pool but it won't suck anything...
    Attachment(s) by palace101 » Tue 24 Mar, 2009 14:06
    8 Replies
    11270 Views
    Last post by Me...
    Thu 26 Mar, 2009 07:05
  • Clicking Sound in Motor
    by Guest » Tue 24 Mar, 2009 19:44
    3 Replies
    1594 Views
    Last post by Guest
    Thu 26 Mar, 2009 01:06
  • flooded pump and sand filter
    by jackflash » Tue 28 Oct, 2008 22:41
    1 Replies
    923 Views
    Last post by jude
    Wed 25 Mar, 2009 03:52
  • pressure back up within a few hours of backwashing the pool
    by txpoolaustin » Wed 15 Oct, 2008 07:14
    11 Replies
    4021 Views
    Last post by ch132212
    Sun 22 Mar, 2009 18:09

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 1 guest