Pool Equipment & Other Pool Maintenance

Automatic pool cleaners, vacuum heads, pool covers,
decks, fencing, pool alarms and security ....
  • Topics
    Replies
    Views
    Last post
  • Pentair WhisperFlo Pump Installation/Wiring
    by iliketowork » Mon 19 Dec, 2011 04:47
    0 Replies
    1021 Views
    Last post by iliketowork
    Mon 19 Dec, 2011 04:47
  • Pool Cover for Free Form Lagoon Pool
    Attachment(s) by tokienu » Sat 12 Nov, 2011 19:41
    1 Replies
    1412 Views
    Last post by rickthespaguy
    Wed 30 Nov, 2011 17:02
  • New sand not filtering enough?
    by Henry_R » Thu 25 Aug, 2011 11:34
    1 Replies
    1346 Views
    Last post by allclearpools
    Mon 28 Nov, 2011 17:11
  • Which automatic pool cleaner to purchase
    by Stuart 1960 » Mon 28 Nov, 2011 05:42
    1 Replies
    718 Views
    Last post by allclearpools
    Mon 28 Nov, 2011 16:54
  • Katchaleaf pool cover
    by clyles » Fri 05 Jun, 2009 14:21
    1 Replies
    1058 Views
    Last post by greeneyedlady
    Tue 18 Oct, 2011 12:05
  • Aqua Rite T-Cell-15 problem
    by papamac5515 » Wed 05 Oct, 2011 17:50
    0 Replies
    521 Views
    Last post by papamac5515
    Wed 05 Oct, 2011 17:50
  • Energy Saving & Co2 reduction
    by marshall » Tue 04 Oct, 2011 06:21
    0 Replies
    509 Views
    Last post by marshall
    Tue 04 Oct, 2011 06:21
  • Pumpmotor of automatic pool cleaning Robot
    by rgalex » Sun 25 Sep, 2011 13:49
    0 Replies
    521 Views
    Last post by rgalex
    Sun 25 Sep, 2011 13:49
  • New De Grids - Same Starting Pressure!
    by tdfuller » Thu 15 Sep, 2011 21:03
    1 Replies
    732 Views
    Last post by mas985
    Fri 16 Sep, 2011 16:35
  • Major Pressure and Suction problems
    by GerhardSA » Tue 13 Sep, 2011 02:36
    3 Replies
    1527 Views
    Last post by GerhardSA
    Wed 14 Sep, 2011 00:52
  • Identification of multiport valve
    Attachment(s) by dbowler » Wed 27 Jul, 2011 10:22
    5 Replies
    3055 Views
    Last post by dbowler
    Wed 24 Aug, 2011 06:53
  • What is what with pool equipment
    by frustratedinNC » Wed 22 Jun, 2011 21:12
    5 Replies
    1857 Views
    Last post by floridapooltech
    Mon 22 Aug, 2011 19:59
  • Rising Pump Pressure
    by kennyholubec » Wed 17 Aug, 2011 10:31
    1 Replies
    957 Views
    Last post by mas985
    Sat 20 Aug, 2011 17:44
  • Poolrite and SureChlor 4000
    by PoolBoy2011 » Sat 20 Aug, 2011 04:37
    0 Replies
    1258 Views
    Last post by PoolBoy2011
    Sat 20 Aug, 2011 04:37
  • Auto Cleaner
    by b50 » Mon 15 Aug, 2011 10:31
    10 Replies
    3099 Views
    Last post by b50
    Tue 16 Aug, 2011 16:49
  • Pool Pump Not Pumping
    by Crothall » Wed 22 Jun, 2011 16:11
    2 Replies
    3387 Views
    Last post by floridapooltech
    Tue 16 Aug, 2011 14:39
  • DE in my pump
    by Keeganr » Tue 02 Aug, 2011 18:05
    1 Replies
    598 Views
    Last post by floridapooltech
    Tue 16 Aug, 2011 14:36
  • water coming out of backwash hose during filtration
    by krista » Wed 26 May, 2010 18:33
    8 Replies
    35349 Views
    Last post by floridapooltech
    Tue 16 Aug, 2011 14:33
  • Pump looses sucktion when Multiport is set to Filter
    by dmjpierce » Tue 10 May, 2011 16:23
    1 Replies
    644 Views
    Last post by floridapooltech
    Tue 16 Aug, 2011 14:25
  • Backpressure
    by Ianole » Mon 01 Aug, 2011 20:31
    1 Replies
    609 Views
    Last post by cpo2go
    Mon 15 Aug, 2011 00:56

Return to Board Index

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 1 guest