DE filter grids do not drain

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts
zack823
Pool Newbie
Pool Newbie
Posts: 1
Joined: Sun 15 Apr, 2018 17:33
My Pool: 22x40 inground DE 8' diving board

DE filter grids do not drain

Postby zack823 » Sun 15 Apr, 2018 17:43

I have a Hayward DE filter that is approximately 3 years old. This season after running the pool a little bit to start clearing it the pressure went up as expected.

Deciding to clean the grids for the start of the season, I backwashed, rinsed, and popped the plug to drain the water. Normally by the time I get the cover off the grids have drained and all is well.

This season the filters over all of the grids are holding the water and took almost two hours for the water to drain. I have been unable to find any similar issue and hope someone can point me in the right direction.

on the filter the pressure raises slightly relatively quickly and the water flow diminishes dramatically. Pump seems fine on all other settings by passing the filter for flow and pressure.

Thinking about replacing the grids but it seems like they should have lasted more than 3 seasons.

Thanks in advance for any suggestions.


Teapot
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 249
Joined: Tue 17 Oct, 2017 10:52
My Pool: 12 x 24 (45m3) liner pool, Triton TR60 filter with AFM glass media (Activate) and variable speed pump running 0.08HP
Location: UK

Re: DE filter grids do not drain

Postby Teapot » Mon 16 Apr, 2018 01:15

Have you tried soaking the grids in a cleaning solution?

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 3 guests