Dirt coming through jets when on waste

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts
mariannecc
I'm new here
I'm new here
Posts: 1
Joined: Thu 16 Jul, 2020 08:52

Dirt coming through jets when on waste

Postby mariannecc » Thu 16 Jul, 2020 08:59

We just renovated our backyard so there was a lot of construction dust etc that ended up in the pool. I quickly realized that no amount of vacuuming was going to remove it, as it kept settling on the bottom every day. I was told to add Power Floc which helped to create larger clumps. So started to vacuum it up on waste and then noticed that dust/dirt was still coming out of the jets while I was vacuuming on waste. I thought that nothing was supposed to come out of the jets while doing this. Am I wrong? Is there something I can do to prevent this. I have repeated this process about 5 times in the last few days. Pool is still dirty. I am so frustrated. HELP!!!


Denniswiseman
Pool Industry Leader
Pool Industry Leader
Posts: 1857
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Dirt coming through jets when on waste

Postby Denniswiseman » Fri 17 Jul, 2020 02:00

Your spider gasket is faulty in your MPV
swimjen
I'm new here
I'm new here
Posts: 1
Joined: Sun 22 Nov, 2020 02:55
My Pool: In ground fibreglass, Saltwater, 10m x 4m, Sand filter, pumps??? (no idea!)

Re: Dirt coming through jets when on waste

Postby swimjen » Sun 22 Nov, 2020 03:32

Sorry if this is not the correct place for my question.
I could not see anywhere on this forum site that clearly said 'Post'
I am having exactly the same problem with brown water coming through the filter jets into the pool... I have only just worked it out as I have been manually vacuuming every 2nd day over last fortnight and wondering why the brown layer on the floor, steps and ledges kept returning. Water seems ok...have done a water test at local hardware store: had to add 5ky of Buffer and a Shock treatment...that is all it needed.
After only just noticing the brown water coming through filter jets, I turned off the pool and turned handle to 'backwash' and turned pool back on. I thought the clear canister was supposed to fill up with water whilst backwashing... and that I was to watch it till it clears = backwash done. I noticed that the 'clear canister' didn't even half fill up whilst backwashing and even more surprising was that the water was clear???.... I would really appreciate anyone's input

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests