Pentair IC40 not making chlorine

SWGs, salt water chlorine generators, chlorinators,
ozone generators, UV systems, . . .
03blackwrx
I'm new here
I'm new here
Posts: 3
Joined: Thu 06 Jun, 2019 13:40
My Pool: 31x13 in ground pool in Ohio. Automatic pool cover, varaible speed Jacuzi pimp, Pentair IC40 salt system

Pentair IC40 not making chlorine

Postby 03blackwrx » Thu 06 Jun, 2019 14:16

Worked fine last year. At start up this year cell light and power light will not come on. Flow is ok. Salt level has been checked twice by Leslies (within rage both times). Was at 3300 now at 3600 (I added.

I cleaned twice correctly w acid/water mix, foamed a bit.

Pool came a house I bought a little over ago. Love the pool.

Any ideas? I really don't want to replace the cell. If i do i would probably jump up to the newer Penatir Ichlor30 unit...


Teapot
Pool Industry Leader
Pool Industry Leader
Posts: 1131
Joined: Tue 17 Oct, 2017 10:52
My Pool: 12 x 24 (45m3) liner pool, Triton TR60 filter with AFM glass media (Activate) and variable speed pump running 0.08HP
Location: UK

Re: Pentair IC40 not making chlorine

Postby Teapot » Thu 06 Jun, 2019 17:42

Power supply problem but no power light on suggests internal fuse blown
03blackwrx
I'm new here
I'm new here
Posts: 3
Joined: Thu 06 Jun, 2019 13:40
My Pool: 31x13 in ground pool in Ohio. Automatic pool cover, varaible speed Jacuzi pimp, Pentair IC40 salt system

Re: Pentair IC40 not making chlorine

Postby 03blackwrx » Fri 07 Jun, 2019 10:03

Teapot wrote:Power supply problem but no power light on suggests internal fuse blown


Ok. I checked fuse at box and it was good. Is there any way to fix? is there another fuse?
03blackwrx
I'm new here
I'm new here
Posts: 3
Joined: Thu 06 Jun, 2019 13:40
My Pool: 31x13 in ground pool in Ohio. Automatic pool cover, varaible speed Jacuzi pimp, Pentair IC40 salt system

Re: Pentair IC40 not making chlorine

Postby 03blackwrx » Mon 10 Jun, 2019 07:50

Teapot wrote:Power supply problem but no power light on suggests internal fuse blown


Is there another fuse? any other ideas on how to troubleshoot? :think:
Teapot
Pool Industry Leader
Pool Industry Leader
Posts: 1131
Joined: Tue 17 Oct, 2017 10:52
My Pool: 12 x 24 (45m3) liner pool, Triton TR60 filter with AFM glass media (Activate) and variable speed pump running 0.08HP
Location: UK

Re: Pentair IC40 not making chlorine

Postby Teapot » Mon 10 Jun, 2019 13:23

Are you any good with a multi test meter? If not hand the job to an electrician.

Return to “Salt Water Chlorine Generators, Ozone, UV”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot], Qwantify [Bot] and 0 guests