Problem with my intellichlor IC40

SWGs, salt water chlorine generators, chlorinators,
ozone generators, UV systems, . . .
Guest

Problem with my intellichlor IC40

Postby Guest » Thu 11 Aug, 2011 00:42

The small magnet should be attached to the stainless paddle in the upstream side of the cell. That is the flow switch. When water flows, the paddle flexes indicating flow. Is the magnet laying in there loose? If so, that is the problem. It has come detached from the paddle.


HWE

Problem with my intellichlor IC40

Postby HWE » Wed 31 Aug, 2011 14:23

I've had an IC-40 about 1.5 years into a new pool construction. Chlorine output is fine. But my unit reads around 4200ppm with all normal lights...but I have physical salt crystals on pool toys after they dry and the water tastes about as salty as the ocean. about 6 months ago the unit read low salt at about 2600ppm. I added the calcualted amount to bring the level to the mid/high 3500 range. Ever since the water seems very very salty for the value the unit is giving me. I've had the water tested at the pools stores getting wildly different levels so I don't trust that measure. I did purchase the salt strips you dip in some of the water...this showed my ppm at around 7000-8000...

Could my units calibration be off needing service repair or could build-up in the unit cause this under reading of the true salt concentration?
LB Guy

Problem with my intellichlor IC40

Postby LB Guy » Tue 18 Oct, 2011 17:51

I am having the exact same problem. Intellichlor reads salt level low but my level is 3900 per Leslie Pools. Anyone find a solution. Everything else is perfect. All chemistry is good but chlorine is going down due to inoperation. Flow is good, etc.
SSinKS

Problem with my intellichlor IC40

Postby SSinKS » Wed 21 Dec, 2011 18:30

I recently bought a house with an indoor (inside a non-heated outbuilding) pool with a complete pentair setup - heater and intellichlor IC40 chlorinator. System was working great through the summer, until a couple months ago. Motor burned out going to the pump, which I had replaced, but since then, the IC40 unit has had a red "flow" light, blank blank cell light, and scrolling salt level lights. All the other lights are green. I've done some troubleshooting already, such as changing filter sand, inspecting intakes/skimmer baskets, etc., but I can't seem to find any obvious flow issues. I took the unit off and did an acid bath after changing the sand, and flow trigger seems to move freely, so I'm basically stuck. Called pentair tech support, and basically got the answer of "change out the chlorinator unit". Just wanted to see if anyone on this forum has had any similar experiences or any advice before I drop a hundreds on a new chlorinator. I'm new to pools and especially new to saltwater pools, so any help would be appreciated. Thanks in advance
RangerRick

Problem with my intellichlor IC40

Postby RangerRick » Mon 02 Jan, 2012 13:06

I have a 2 year old Intellichlor IC40 that is in need of repair. The unit will not make any chlorine. The salt indicator light is red. So I had the salt level tested at the local pool supply it was at 3200ppm. So I added a bag of salt bringing the salt level up to 3300 and it made chlorine for a one cycle. I added more salt to 3400 and it worked for a few hours. Now I am above 3800 and the salt indicator is still red and chlorine output is zero. I have looked everywhere for a replacement salt sensor or someone who can make this repair. Can anyone help or point me in the right direction. THANK YOU !

Yes, the chlorinator has cycled (rebooted).
Yes, the cell has been acid washed.
Yes, the salt level has been professionally tested.
The problem is the chlorinator NOT the user.
jaya moodley

Problem with my intellichlor IC40 red pwr light

Postby jaya moodley » Wed 15 Feb, 2012 05:59

HoustonTexas wrote:I have a Intellichlor IC40 and it reads REd PWR light on the status section. Troubleshooting section says it need service. Whatr exactly does that mean. The unit is only 16 months old.
anyone know what service means? :?:
stevemurphy1

Problem with my intellichlor IC40

Postby stevemurphy1 » Sun 26 Feb, 2012 17:23

I too have an Intellichlor IC40 and noticed a few weeks ago, after a rain storm that it was reading low salt (2400 ppm). I put 120lbs of salt in the pool (it's 30,000 gallons) and the chlorinator started reading 7800 ppm. I let it run a few days and it went back down to 2400 and low salt light was on. I added another 120lbs and the reading didn't change. I had my water tested at Leslie's and it reads 4000 ppm. I acid cleaned the unit and everything seems intact but now it's reading 2650. The pool is 1 1/2 years old so I am wondering if the unit is bad or if there is some way to "reboot" it to see if it will correct itself or should I run it a few more days and see if it changes. Any help would be appreciated.
bestestbuddy

Problem with my intellichlor IC40

Postby bestestbuddy » Mon 05 Mar, 2012 15:15

I have a similar problem and so I've been doing research. The intellichlor measurement is not temperature compensated, so it reads 200ppm low for each 5 degrees below 77 F. In addition, the cell light will not turn on if the water temperature is 52 +/- about 5 degrees. My water measures 3500ppm with a temp compensated gauge, but the intellichlor (through easy touch) reads the salt as 2600ppm. Since my water temp is around 54 degrees, I think the math makes sense. The best thing to do at this point is to just chlorinate it manually during the cold season, it doesn't need much any way. When the weather warms up, things will turn on again. Probably the worst thing to do right now is to add salt in response to the easy touch read out. If you make it read 3500ppm now and your water is as cold as mine, your going to be dealing with 4500ppm water later.
wetworld

Problem with my intellichlor IC40

Postby wetworld » Sun 01 Apr, 2012 12:45

All the lights went out on my 2yrs old IC40 this week but the machine is operational and still creating enough chlorine to satisfy pools need - just can't see the lights which makes this quite troublesome indeed...what do i have to do to fix this problem?
dsdman

Problem with my intellichlor IC40

Postby dsdman » Tue 08 May, 2012 14:26

I have the exact same issue. It sounds like the cells inside are making bubbles and the pool is clear but I have no lights what so ever on the intellichlor unit. I've tried everthing, disconecting power, pressing both buttons at the same time and sacraficing small frogs to it,(well they were already dead) filter basket casualty and all. But nothing happens on the controll panel...nada, zip. So Since no one from pentaire will way in and tell us what to do I will never ever buy any of their stuff again as long as I live. That is a promise. Don't waste time calling them, it is more of a waste than reading these post! :)
beachman

Problem with my intellichlor IC40

Postby beachman » Sun 05 Aug, 2012 12:57

I have an intellichlore unit and none of the lights are lit. Has anyone had this issue before and if so how did you get it resolved? I have check :eh: ed the mother board and all the compasators look and check out OK.
Cajuncolonel

Problem with my intellichlor IC40

Postby Cajuncolonel » Fri 31 May, 2013 12:22

I have the same problem with my Intellichlor IC40. No lights. I'm checking the fuse on the power generator and then for 22-39 volts coming off the transformer on the black and red wires. I'm still troubleshooting mine.
showtime

Problem with my intellichlor IC40

Postby showtime » Sat 13 Jul, 2013 10:43

I have the same problem as well, IC40 is working but no lights at all. Pentair tech help is useless. They just say to replace it. it is only 2 yrs old. What a waste of money on this company! :(
F Bosbous

Problem with my intellichlor IC40

Postby F Bosbous » Sat 17 May, 2014 09:15

I had a functioning intellichlor system going on 5 years now and about a week ago everything went blank (no lights). FYI - There is no separate intellichlor power center. It is incorporated into the Easy Touch panel.

I have pressed the reset button and the light on my panel shows green that the intellichlor is working. There is still no life in the cell and it does not look like it"s communicating with the control panel. I have cleaned the cell and there is no calcium build up.

They say the intellichlor cell lasts for about 5 years and will replace, but I hate to replace the cell and still come up with the same communication problem only to find out the original cell was ok?

Any thoughts? and thanks in advance for guidance.
Tulanemom
I'm new here
I'm new here
Posts: 1
Joined: Mon 30 Jun, 2014 18:24
My Pool: Gunite pool - 16x36
Sand filter
Pentair intellichlor salt cell
Location: Louisiana

Problem with my intellichlor IC40

Postby Tulanemom » Mon 30 Jun, 2014 18:55

I have a problem with my IntelliChlor Chlorine generator. This is my third. The first was great - replaced after about 5 years with no problems during that time. Soon after the 2nd was installed, the jets in the pool began shooting out white sandlike particles into the pool. Enough that I brush it and within just a short timeframe the bottom is covered again. After a whole summer of complaining to pool company - where I purchased cell - taking sandlike particles into store, cleaning cell - twice, and numerous chemical treatments, they replaced cell which was still under warranty. Worked great for about 6 months. Now I am having the SAME issues again! Pool company - so far - is unable to have a solution, but unwilling to replace until we try cleaning, chemicals, etc. Do not want another summer of issues with this cell! Anyone have this problem, or have a solution?

Return to “Salt Water Chlorine Generators, Ozone, UV”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests