Pool filter loses prime when shut off

Leaks in the pool, plumbing, filtration system, skimmer, ...
Finding & repairing swimming pool leaks.
spanishpoolguy
Pool Newbie
Pool Newbie
Posts: 2
Joined: Tue 14 Jun, 2011 05:57
My Pool: 5 x 3 metre in-ground w/Astral Sena pump, Astra Millenium sand filter
Location: Sevilla

Pool filter loses prime when shut off

Postby spanishpoolguy » Sat 18 Jun, 2011 13:23

PROBLEM SOLVED!!
Took off pump basket 'O' ring seal, cleaned it and applied a little bit of silicon grease to it. Similarly, did the same to filter top 'O' ring seal, replaced them both and hey presto! Pump stays primed!! :D I am fairly certain that the main culprit in this case was the filter top 'O' ring seal not sealing/seated properly, which was allowing air to be sucked into the system. I've learnt so much over the last couple of weeks, I'm considering becoming a pool maintenance guy full time!!


johan

Pool filter loses prime when shut off

Postby johan » Tue 08 Nov, 2011 06:24

Hi
My problem as follow.
When the pump is running everything seems normal, no air boubles etc. When I switch the pump of I can see and hear a gulp of air coming from filter towards the pump and filling the Stainer bucket and resulting in the pump running dry when started agiain.
If I turn the direction valve to "bypass" in order to bypass the filter, the problem don't occur.
This tels me that air somehow acumulates in the filter and isforced back to the pump side.
What can cause this?
I replaced the filter lid seal, didn't make a difference.
debrr1

Pool filter loses prime when shut off

Postby debrr1 » Thu 10 Nov, 2011 19:56

Can u please tell me what the water trick is with the hose and the shaving cream trick on fittings? Thank u!
Frederick Potgieter
Pool Newbie
Pool Newbie
Posts: 1
Joined: Mon 19 Mar, 2018 14:56
My Pool: 24k liters. Marbelite. .75hp pump.

Re: Pool filter loses prime when shut off

Postby Frederick Potgieter » Mon 19 Mar, 2018 15:05

Hi experts. My pool loses prime a d two things happen to put uou on the right trail. When I switch it on ot makes bubblws on the shortest inlet valve from the pump only. When I switch it off I hear a hiss sound/blow sound on the valve for more than an hour agterwards...where I backwash/rinse/.
Any ideas.whay might be wrong?
Much appreciated....also....today I saw water on the floor under the motor.
Thank you all.
Denniswiseman
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 830
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Pool filter loses prime when shut off

Postby Denniswiseman » Mon 19 Mar, 2018 15:51

You seem to have a suction side air leak
Check your pump basket lid "O" ring (lubricate with silicon grease) and joints on the suction side
Is the water level 1/2 to 2/3 up the skimmer inlet and the skimmer door isn't jammed up

Return to “Swimming Pool Leaks”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests