Polaris 360 sweep doesn't sweep

Automatic pool cleaners, vacuum heads, pool covers,
decks, fencing, pool alarms and security ....
zacman

Polaris 360 sweep doesn't sweep

Postby zacman » Sun 16 Jul, 2017 10:05

I have a Polaris 360 pressure side cleaner - 20 years old but I have repaired it from time to time so much is new and upgraded. The only issue I have is that the "tail" - or sweep, does not snake around like it did when new, and like it will show in video demonstrations. That is, it does not move around from side to side any more but just drags behind in a straight line. I have tried to adjust the valve to the sweep from high to low but it does not change anything. I have cleaned the sweep hose and then replaced the sweep hose but it still just drags along. Interestingly, I don't know what would make it snake around anyway, but it is supposed to do that. So, I am looking for suggestions. Do I need to move the weights around, or do anything else with the hose? I have the rubber sponge at the end. Any help will be greatly appreciated.


Denniswiseman
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 601
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Polaris 360 sweep doesn't sweep

Postby Denniswiseman » Sun 16 Jul, 2017 11:11

If you have replaced everything as it was before, then check you have sufficient flow from your returns, backwash your filter and block any other return
You could try posting on http://www.troublefreepool.com to see if someone their has the same problem
zacman

Re: Polaris 360 sweep doesn't sweep

Postby zacman » Sun 16 Jul, 2017 15:49

Thanks. I have done that.
zacman

Re: Polaris 360 sweep doesn't sweep

Postby zacman » Thu 20 Jul, 2017 15:11

Issue is resolved. The new tail arrived and I installed it today. It snakes around perfectly. The issue was, I am certain, that the old white ribbed hose was very stiff and inflexible. The new one is clear tubing and much more flexible. As soon as I put it on and started it up it took off and snakes back and forth.

So, if anyone else has this issue, consider a new clear plastic sweep - tail.

Return to “Pool Equipment & Other Pool Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests