Suction Loss

Stairs, skimmers, jets, drains, lighting, water features
and miscellaneous pool water fixtures and fittings.
jvvsam01
I'm new here
I'm new here
Posts: 2
Joined: Tue 06 Aug, 2019 07:10

Suction Loss

Postby jvvsam01 » Tue 06 Aug, 2019 07:20

I have a problem that I do not know how to fix. When I connect my Zodiac Pacer automatic pool cleaner it runs for a while and then looses suction power. I have replaced all the hoses of the cleaner, put in a new diaphragm and a new automatic weir valve. Air bubbles is also coming out of one of the inlet jets in the pool. If I disconnect the automatic cleaner from the weir the air bubbles stop. The moment I connect the cleaner again it starts to form these bubbles. Sometimes the cleaner runs for an hour without problems and other times only 10 minutes.


Denniswiseman
Pool Industry Leader
Pool Industry Leader
Posts: 1262
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Suction Loss

Postby Denniswiseman » Tue 06 Aug, 2019 15:58

You have a suction side air leak from your skimmer to your pump. Check the "O" ring of your pump basket strainer and lubricate with silicon grease. Also drain plugs and inlet connection
You will also notice that the water i the pump basket will empty or lower
jvvsam01
I'm new here
I'm new here
Posts: 2
Joined: Tue 06 Aug, 2019 07:10

Re: Suction Loss

Postby jvvsam01 » Tue 13 Aug, 2019 07:24

Thanks Dennis,

I will check that. The water level in the pump basket do drop as it goes on.

Return to “Skimmers, Jets, Lighting & Other Pool Fixtures”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests