Hayward H400IDL2 pool/spa heater suddenly blazing hot!

Electric heaters, gas heaters, heat pumps,
solar heaters, geothermal heating, solar pool
covers and wood-burning pool heating equipment.
sid
I'm new here
I'm new here
Posts: 1
Joined: Thu 26 Mar, 2020 13:15
My Pool: rectangle shaped pool built back in the late 80's. Approx 20' x 40' and 4' in depth. Original Pac Fab SS filter and Hayward pool heater

Hayward H400IDL2 pool/spa heater suddenly blazing hot!

Postby sid » Thu 26 Mar, 2020 13:31

Hello All,
I am hoping someone can point me in the right direction as to what's going on with my pool heater. I purchased a second hand H400IDL2 about two years ago. Last year I had to replace the bypass insert and thermal control valve and that corrected the banging issues I was getting. This year I got an error code and after troubleshooting found that the capacitor for the fan blower motor was bad. I replaced that and it's been running fine until yesterday. I was heating the spa up from 70 ish to 90 when I heard a noise. I went over to heater and could hear the heat clicking on and off - i am guessing this is a fire protection kind of thing. The airflow was going but the burners would kick off and a few seconds later try to come back on. The whole heater unit was extremely hot to the touch. I cooled down the unit with a water hose and the heater operated just fine but continues to get VERY hot. The heat exhaust seems too be much hotter than it has ever been and the metal even turned white from the heat. I tried searching everywhere but can't find any advice on what's going on. I am guessing there is some kind of thermal control that has gone out but can't find any info on it. Anyone got any ideas?
Thanks in advance for any help you can offer.
Sid


Gregp
I'm new here
I'm new here
Posts: 2
Joined: Mon 16 Nov, 2020 22:05

Re: Hayward H400IDL2 pool/spa heater suddenly blazing hot!

Postby Gregp » Tue 17 Nov, 2020 00:02

I have a similar issue except I saw what appears to be the starting of lye flames in the vent so I quickly turned it off. Did you ever figure out your problem?

Return to “Solar & Pool Heaters”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests