Vacuum hose causing air bubbles

Problems relating to the Pool Help Forum website and general forum help.
Suggestions and criticisms that would improve your web experience.
CoVex55
Pool Newbie
Pool Newbie
Posts: 1
Joined: Sun 23 Jul, 2017 16:27

Vacuum hose causing air bubbles

Postby CoVex55 » Fri 28 Jul, 2017 23:14

Once I connect my vacuum hose to the dedicate inlet hole on the inside of the pool air bubbles start to come out of my return valves. I have made sure there is no air in the hose or vacuum and checked my skimmer and made sure no air was being sucked in. As soon as I disconnect the hose from the wall and allow the water to be sucked in with no hose the air bubbles go away. But as soon as I put the hose back into the inlet hole the air bubbles come back. Does anyone know why this would happen? I have been trying to fix this for a week.


Denniswiseman
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 711
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Vacuum hose causing air bubbles

Postby Denniswiseman » Sat 29 Jul, 2017 00:56

You have a suction side air leak, when you connect the vacuum hose you put an extra load on the system causing it to suck in air
Check and lubricate with silicon grease your pump "O" ring also check your drain plugs have been sealed and other joints are OK

Return to “Problems & Suggestions for this Forum”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests