Pool filter troubles

Problems relating to the Pool Help Forum website and general forum help.
Suggestions and criticisms that would improve your web experience.
Chuckvader
I'm new here
I'm new here
Posts: 2
Joined: Wed 24 Jun, 2020 15:20
My Pool: I don't know much about my pool, it's 18,000 gallons, its got a star-rite filter model number 135 GPM-TX, and has a hayward max Flo vs model number sp2303vsp.

Pool filter troubles

Postby Chuckvader » Wed 24 Jun, 2020 15:27

I recently started living in a house with a pool on the backyard. The pool was green and filled with dirt and bugs, but I wanted clean it. I've gone through many chemicals and vacuuming sessions to get the pool more clean. The pool is much more clear now and has much less dirt, but I recently starred having a problem with my filter/pump starts pumping out dirt and debris (that I suspect might be from the filter) when I start vacuuming dirt. Any suggestions?


Denniswiseman
Pool Industry Leader
Pool Industry Leader
Posts: 1827
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Pool filter troubles

Postby Denniswiseman » Thu 25 Jun, 2020 01:47

There may be a hole in the cartridge letting the debris through
Have you backwashed the filter
Chuckvader
I'm new here
I'm new here
Posts: 2
Joined: Wed 24 Jun, 2020 15:20
My Pool: I don't know much about my pool, it's 18,000 gallons, its got a star-rite filter model number 135 GPM-TX, and has a hayward max Flo vs model number sp2303vsp.

Re: Pool filter troubles

Postby Chuckvader » Thu 25 Jun, 2020 09:39

Denniswiseman wrote:There may be a hole in the cartridge letting the debris through
Have you backwashed the filter

I'm kind of new to this stuff and I don't actually know how to backwash the pool with my specific setup. I wash the filter pretty regularly with a hose.
Denniswiseman
Pool Industry Leader
Pool Industry Leader
Posts: 1827
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Pool filter troubles

Postby Denniswiseman » Thu 25 Jun, 2020 16:41

I'm not familiar with cartridge filters, you may not be able to backwash
I suspect that you have a hole in your cartridge or it isn't seated correctly

Return to “Problems & Suggestions for this Forum”

Who is online at the Pool Help Forum

Users browsing this forum: CommonCrawl [Bot] and 0 guests