Big mistake with algicide

Algae problems in swimming pool water.
Green (cloudy) water or slimy pool walls.
Black algae. Mustard algae. Pink or white pool mold.

Big mistake with algicide

Postby DaveTX » Wed 16 Feb, 2011 13:13

My Dad put a gallon of algicide into a 15,000 gallon pool. Now there is a layer of foam over the entire surface. How do we fix this. Any help would be appreciated.


Big mistake with algicide

Postby DaveTX » Wed 16 Feb, 2011 13:17

OOPS, sorry I should have searched first.
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 401
Joined: Sat 16 May, 2009 09:20
My Pool: 16 x 32 gunite21000 gal., Diamond Brite Blue, Swimquip XL pump, DE36
Location: Texas

Big mistake with algicide

Postby czechmate » Mon 21 Feb, 2011 21:37

Mistake may have been to use algaecide in a 50 degree water period. As expensive this treatment is, you only use it when you have to. Pool store may tell you to use it as a preventive measure. It is a BS, since they already sold you the Cal-Hypo for a shock at premium price. In this cold weather algae is dormant, retarded or not present at all. All you need to do is maintain the FC level 10% of CYA in the pool and watch your CSI for possible scalling.
As far as the suds goes, it is harmless. I assumed in this reply, that you are in Texas.
So even with a heater you have probably still a few weeks to start season anyway.
(Unless you want to shell out some extra dough to TXU for few laps in still pretty cold water.......... :)

Return to “Pool Algae & Green Pool Water”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests