Green pool water, pump will not circulate in filter mode

Algae problems in swimming pool water.
Green (cloudy) water or slimy pool walls.
Black algae. Mustard algae. Pink or white pool mold.
scott22620
Pool Newbie
Pool Newbie
Posts: 1
Joined: Thu 12 May, 2011 19:56
My Pool: 27 Foot round aboveground.
Location: Murfreesboro

Green pool water, pump will not circulate in filter mode

Postby scott22620 » Thu 12 May, 2011 21:39

We are new to pool owning and are learning as we go. I removed the cover to open the pool for the season and low and behold.... Algae!

I filled the pool up to opperating level, poured a bottle of shock in to the pool and turned it on to filter mode. I ran the pool for two days and nothing changed. I vacuumed the bottom of the pool backwashed the filter hoping it would help. We added chlorine and baking soda then let the pump run in filter mode, again no change. A friend suggested that I vacuume it to waste then run in filter mode so I did. I came home the next evening and no changes in the pool color and the pump was barely circulating the water. I tried backwashing the filter and rinsing but it didn't help. I'm taking a gander that the filter media is overly packed with algae. I thought about shocking the pool again and running the pump in recirculate mode for a few days then vacuuming it to waste. If the water comes out clean I can then backwash and rinse the filter a few times to try to clean the filter media.


Please somone with more experience can you give me some suggestions.


poolboy911

Green pool water, pump will not circulate in filter mode

Postby poolboy911 » Sat 28 May, 2011 06:20

If it's a sand filter then open the top and check that the sand is loose and in good condition. You could try a filter cleaner if there is clumping of the sand.
MROMAN559

Green pool water, pump will not circulate in filter mode

Postby MROMAN559 » Mon 30 May, 2011 22:23

I have a friend that had a similar problem with a sudden loss in pressure...... check the impeller in side your pump. His was full of junk.....cleaned it out and now runs like a brand now pump.

Return to “Pool Algae & Green Pool Water”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 1 guest