Spa Jets and Pump Problems

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
Pool Newbie
Pool Newbie
Posts: 1
Joined: Thu 09 Jun, 2011 23:05
My Pool: 30 year old inground gunite pool with spillover spa, 50000 gallons, headache inducing. Three 2hp challenger pumps with heater unhooked
Location: Little Rock

Spa Jets and Pump Problems

Postby blakeruff » Thu 09 Jun, 2011 23:15

We have an older pool, we drained it this year and painted it. After the fill, we noticed only half of our spa jets we working ( four out of eight ) with two blowing extremely strong. We replaced the old pump to a 2hp Challenger pump. When we removed the old pump the intake plumbing would not stop running water. It eventually ran dry and we completed the swap. After priming the new pump we noticed the jets were still not working and water is flowing freely again upon removing the strainer basket. I am still sort of new to this, so I am at a loss. Is something clogged? We unhooked and plumbed around the heater last year, until we can afford a new heater. Was that a mistake? Any help or further discussion is greatly appreciated..

User avatar
Swimming Pool Pro
Swimming Pool Pro
Posts: 199
Joined: Tue 08 Sep, 2009 10:40
Location: Pleasanton, CA, USA

Spa Jets and Pump Problems

Postby mas985 » Sat 11 Jun, 2011 11:58

Something could be stuck in one of the spa jets. See if you can remove the nozzles and flush out the line.
Hydraulics 101 ; Pump and Pool Spreadsheets ; Pump Ed 101
18'x36' 20k gallon plaster/gunite pool, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge Filter, Solar Panels, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 1 guest