Polaris Backup Valve & Hose Compression Fittings

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts
JTGrace

Polaris Backup Valve & Hose Compression Fittings

Postby JTGrace » Sat 17 Sep, 2011 09:09

I am trying to replace my Polaris Backup Valve, but can't disconnect the hose from the top and base of this giant white acorn. I have tried unscrewing the compression fittings (nuts), but it just keeps spinning and never backs off. I have also tried simply pulling it off (caveman style), but that didn't work either. What's the trick?


czechmate
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 401
Joined: Sat 16 May, 2009 09:20
My Pool: 16 x 32 gunite21000 gal., Diamond Brite Blue, Swimquip XL pump, DE36
Location: Texas

Polaris Backup Valve & Hose Compression Fittings

Postby czechmate » Sun 16 Oct, 2011 19:38

Backup valve is 2 parts shell, screwed together in middle.
It is fairly hard to unscrew without leaving a channelocks marks on the plastic.
Usually hitting it while fastened in a vise works beter than steadily applied pressure by chanelock pliers. (Always wrap in old leather gloves to minimize damage).
mandycole24

Polaris Backup Valve & Hose Compression Fittings

Postby mandycole24 » Mon 05 Dec, 2011 16:01

Did you find a solution to this? I am having the same problem

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests