Algae after 3 weeks with no electricity

Algae problems in swimming pool water.
Green (cloudy) water or slimy pool walls.
Black algae. Mustard algae. Pink or white pool mold.
Zyriak
Pool Newbie
Pool Newbie
Posts: 6
Joined: Sat 28 Apr, 2012 16:02
My Pool: Size: Info will come.
Surface: Tiles
Filter: Sandfilter (more info will come)
------------------------
Equipment and Chemicals:
Testing Strips:AquaChek 15-Seconds Pool Test.
Chlorine:Granules 90% (Brand will be updated).
pH+/pH-:Granules (More Info Later).
Algeacide:Nu-clo's Poly 50 & Copper 7.
Location: Paphos - Cyprus

Algae after 3 weeks with no electricity

Postby Zyriak » Tue 01 May, 2012 03:32

Hi.
After moving to Cyprus and moved into a villa, with a pool ( have no specs on the pool, but i will add later )
and then with 3 weeks with no electricity ( still water and no circulation + not right chemical balance to start with ) it turned green. The power is now back and i started with the pool about 5 days ago.
Started off by wasting a lot of water, back flush and rinse the filter, then i added a good dose of Algaecide (Copper 7) and 10 scoops of chlorine ( granules 90% ) And with the pump on for about 36 hours. I soon realized that 10 scoops was like throwing a bucket in the ocean, so after adding more over the next days and my test strips did not even react (ppm FREE chlorine = 0 )to the chlorine levels I yesterday added a real overdose of chlorine. the levels suddenly went sky high.(ppm FREE chlorine = 10+). I was a bit afraid at this point since the test strips (AquaChek 15-Second pool test strips) only go to level 10 and i then didn't know if it was WAY over 10.. Today it has actually dropped a bit, so now it shows ppm FREE chlorine somewhere between 5 and 10. Since i started to clean / clear up the pool i have vacuumed several times, and netted up the leafs that was in the pool, Yesterday the water was much better and its definitely starting to clear up, yesterday it was a blue-green-cloudy pool, today its still cloudy, and more blue than green, but now i can actually see the tiles at 1,5 m dept.. the pool is 1m in one end and 2 in the other.
The pH level was about 6,5 so i added Sodium Ash to raise it to about 7.2 +

Anyway. Do you think i have done this right? or is there something you would like to comment on?

By the way. Excuse my English, and yes. I'm a bit new to the world of pools, since I'm from Norway.
But i want to learn more about it, and want to do the things right.

-ZyR-


Zyriak
Pool Newbie
Pool Newbie
Posts: 6
Joined: Sat 28 Apr, 2012 16:02
My Pool: Size: Info will come.
Surface: Tiles
Filter: Sandfilter (more info will come)
------------------------
Equipment and Chemicals:
Testing Strips:AquaChek 15-Seconds Pool Test.
Chlorine:Granules 90% (Brand will be updated).
pH+/pH-:Granules (More Info Later).
Algeacide:Nu-clo's Poly 50 & Copper 7.
Location: Paphos - Cyprus

Pictures of the project!

Postby Zyriak » Tue 01 May, 2012 08:09

This is how it looked at first:
Image

After adding chlorine and algaecide (dead algeas floting on top, this i scooped out with a bucket):
Image

2 days later, after adding more chlorine, backflushed, rinsed, scrubbed and netted out all leafs:
Image

Today (Day 5) netted out all bugs, new small leafs, brushing and vacuumed more + added soda ash to get the pH up:
Image
Zyriak
Pool Newbie
Pool Newbie
Posts: 6
Joined: Sat 28 Apr, 2012 16:02
My Pool: Size: Info will come.
Surface: Tiles
Filter: Sandfilter (more info will come)
------------------------
Equipment and Chemicals:
Testing Strips:AquaChek 15-Seconds Pool Test.
Chlorine:Granules 90% (Brand will be updated).
pH+/pH-:Granules (More Info Later).
Algeacide:Nu-clo's Poly 50 & Copper 7.
Location: Paphos - Cyprus

Algae after 3 weeks with no electricity

Postby Zyriak » Tue 01 May, 2012 16:28

Date: 01:05:2012
time: 23:00
ph: 6,3
chlorine: 4,5 - 5
ppm tot alk: 45
ppm stabilizer: 25

added chlorine: 5 scoops
added sodium ash: 5 scoops

--------------------------------------------

date: 02:05:2012
time: 00:00
ph: 6,9
chlorine: 10+
ppm tot alk: 60
ppm stabilizer: 55

added chlorine: none
added sodium ash: none

Return to “Pool Algae & Green Pool Water”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests