Sta Rite Heater will not fire

Electric heaters, gas heaters, heat pumps,
solar heaters, geothermal heating, solar pool
covers and wood-burning pool heating equipment.
CGPoolman
Swimming Pool Pro
Swimming Pool Pro
Posts: 168
Joined: Sat 28 Apr, 2012 17:52
Location: Orlando FL

Sta Rite Heater will not fire

Postby CGPoolman » Tue 08 Oct, 2013 10:30

I have a Sta Rite heater giving some attitude.

It is the "Black Egg" model, I'm not sure of the exact model # of this one, I don;t work on very many of these.

According to the homeowner, the heater has worked without issue for several years. It recently ran out of gas and he had the tank refilled. Since then, it will not light. When I turn the heater on, it powers up and the blower kicks on. I get a click when the gas valve opens and I can smell gas. The "Heating" light blinks for about a minute, then goes out. The "Service Heater" light then comes on and stays lit.

I looked at the circuit board, and none of the error lights are on - only the "Spa" and "Service Heater" LED's are lit up. I called Pentair support and they had me test the ignitor. The power to the ignitor was OK, but when testing the ohms it was all over the place. I was advised to replace the ignitor and try again.

I put the new ignitor in last night but that didn't change anything. Still getting the same thing when I try to start the heater. I called Pentair again and they gave me the following options:

1) Ignition module could be bad (it sends good power to the ignitor tho)
2) Faulty circuit board (woudl explain why the error LED's are not lighting)

The tech also mentioned to check the gas pressure, I do not have a meter for this but my boss does. I'm trying to coordinate with him a night this week where we can meet at the house and test the gas pressure.

Anyone have any advice? Below is a photo of the circuit board if that helps.

-CG
Attachments
stariteheater.jpg
Only 2 LED's are lit - the "Spa" and "Service" light
stariteheater.jpg (79.46 KiB) Viewed 1963 times


CGPoolman
Swimming Pool Pro
Swimming Pool Pro
Posts: 168
Joined: Sat 28 Apr, 2012 17:52
Location: Orlando FL

Sta Rite Heater will not fire

Postby CGPoolman » Wed 09 Oct, 2013 19:46

I went back to this house tonight with my supervisor where he tested the gas pressure. It was reading very low, so we went and looked at the gas tank on the side of the house and was just a hair above zero. I didn't even think to look at the tank the first time since the homeowner said they just had it filled. Somewhere there is a gas leak - either out by the tank, or the gas valve inside the heater is faulty, not closing all the way allowing the gas to leak out. Homeowner is going to have the gas company out there in the next few days to check the lines. If everything else checks out OK, then it must be the gas valve.

-CG

Return to “Solar & Pool Heaters”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests