Low flow on Filter setting

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts
Pool Newbie
Pool Newbie
Posts: 1
Joined: Thu 12 Jun, 2014 08:25
My Pool: 26' Above ground with Hayward Power-flo LX Pump SP1510-Z-1XESC 100 gallon filter.
Location: Rome Ny

Low flow on Filter setting

Postby 06sporty1200 » Thu 12 Jun, 2014 08:48


I am at my wits end with my pump/filter this year, I keep losing flow when on filter.
My pump looses pressure after about 5 minutes on the filter setting, It holds pressure fine on the recirculate setting.

What I have done so far:

Changed my sand again (it’s was only used for 2 seasons) because it was blowing dirty water back in the pool . Note my laterals are only 3 or 4 years old

Changed the o-ring on the pump strainer

Checked for leaks on all the suction plumbing and added an extra clamp to all the lines

Took the head off and lubed all the o-rings

Changed the impeller seal (ordered a new pump housing o-ring the pool store didn’t have any in stock)

Question is if I am holding good flow on recirculate setting, is the problem in the head unit or sand filter, or what???

Hayward Power-flo LX Pump SP1510-Z-1XESC

Swimming Pool Pro
Swimming Pool Pro
Posts: 168
Joined: Sat 28 Apr, 2012 17:52
Location: Orlando FL

Low flow on Filter setting

Postby CGPoolman » Fri 13 Jun, 2014 10:17


Sounds like you have hit all the normal troubleshooting. If the "Recirculate" is good, you have ruled out a pump or plumbing issue. Your pressure drops when on "filter", I would say most likely your problem is inside that filter. You could try taking the lid off that filter valve and see if anything is stuck in there. Also check the tube that runs down the middle of the tank for any clogs, it's not uncommon for sand to get down in there when pouring in the new stuff. You may want to empty the sand out of the tank and give it a good once over for any debris that could be screwing things up in there. Over the years I've found all sorts of things inside the sand filter.

Pool Newbie
Pool Newbie
Posts: 7
Joined: Mon 08 Feb, 2016 05:43
My Pool: Small pool with granite counter tops and many more things.
Location: Sugar Land, TX

Re: Low flow on Filter setting

Postby bryanwalker » Fri 18 Mar, 2016 02:39

Nice job Poolman...

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 2 guests