Lost presure in skimmer

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
Pool Newbie
Pool Newbie
Posts: 1
Joined: Sat 16 Apr, 2016 12:40
My Pool: Older pool, not very large. Chlorine.

Lost presure in skimmer

Postby ebausewein » Sat 16 Apr, 2016 12:43

I'm having an issue with my skimmer line pressure. It has been working fine until about 2 weeks ago when the has almost completely stopped. Now if I use just that line, it doesn't fill the basket up with water and I don't really know how to describe it, very low water, then a quick burst, then nothing. I've tried ballooning both ends and water comes through fine, I don't know what to do

Pool Enthusiast
Pool Enthusiast
Posts: 11
Joined: Thu 14 Apr, 2016 04:23
My Pool: Speck pump 0.75,in ground pool,11x4 meters,3 bag filter.solar heating

Re: Lost presure in skimmer

Postby Dewald » Mon 18 Apr, 2016 03:15

Replace your pipe between the pool and pump.You have a leak there,i had the same problem and thats fixed now but now the skimmer is full of water and no air in i still loose presure.
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 322
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Lost presure in skimmer

Postby Denniswiseman » Mon 18 Apr, 2016 04:56

I wouldn't replace the line yet
Check the "O" ring of the pump strainer basket and lubricate it

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 1 guest