Aqua Rite Problem

SWGs, salt water chlorine generators, chlorinators,
ozone generators, UV systems, . . .
Mjcox

Aqua Rite Problem

Postby Mjcox » Sun 29 Apr, 2007 21:58

I had my Aquarite system installed last week and I cannot keep it generating chlorine for more than a minute or so. It shows it is generating and then after about a minute the CHECK SALT and INSPECT CELL lights come on. At first I was not sure of what was happening but after hitting the diagnostics button the cell voltage starts at about 25 to 26 and then quickly increases to around 31 and that is then you here a click and the generating stops and the generating light goes off and the other two lights go on. I am not sure of what is causing this. Electrical work and plumbing are to specifications given in the installation guide. Also the cell current starts at around 3.0+ and when you here the click it drops to zero. Does anyone know what would cause this. I have spoken with Goldline and they are sending someone out to look at it but I was just curious if anyone knows anything about. Any feedback is much appreciated.


dynamictiger
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 254
Joined: Thu 23 Nov, 2006 17:23
Location: Perth, Western Australia

Postby dynamictiger » Mon 30 Apr, 2007 15:37

This is a little like the older chlorinators used to behave when teh salt level was too high.

HTH
mjcox

Postby mjcox » Mon 30 Apr, 2007 18:42

That's just it. The salt level is not too high. I had it professionally tested and it came up as 3300ppm and I also did a salt test strip and it came up as 3400ppm. I am not sure of what the problem is but it is under warranty and Goldline has informed a local pool company to come out to see what the problem is. I was just curious if maybe someone else may have had the same problem as myself.
mjcox

Postby mjcox » Sat 05 May, 2007 13:26

Aquarite has fantastic customer service. They sent someone over and fixed the problem for me. Quite simply, it was a bad cell. You cannot go wrong with Aquarite.

Return to “Salt Water Chlorine Generators, Ozone, UV”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 9 guests