Brown residue in chlorine generator cell and pipes

Stains on the pool surfaces, pool equipment
or on the swimmers, or off-color swimming pool
water. Discolored but clear pool water.
Pool Newbie
Pool Newbie
Posts: 2
Joined: Tue 22 May, 2007 14:41
Location: Counce TC

Brown residue in chlorine generator cell and pipes

Postby jllyles » Mon 28 May, 2007 12:46

I installed an aquarite chlorine generator a few weeks ago. This weekend I noticed a brownish residue in the jets going into the pool. Out of curiosity I removed the chlorine generator cell for inspection. Upon inspection I found that one side of the cell on the discharge end was covered with a rust looking residue. This residue is also in the pipes on the outlet side of the cell. It is only on one side. Any ideas on what is causing this and what I need to do to fix the problem.

I have been having trouble getting chlorine in my pool but not sure if these are related.

Please Help

Swimming Pool Superstar
Swimming Pool Superstar
Posts: 254
Joined: Thu 23 Nov, 2006 17:23
Location: Perth, Western Australia

Postby dynamictiger » Mon 28 May, 2007 17:19

I suspect this is iron staining, and most likely is coming out of solution inside the chlorine cell. If this is the case this will explain the lack of chlorine. I thin k if you continue to run the cell you will eventually generate more chlorine than iron and come out on the right side.

However, in researching salt chlorinator issues in the USA I have noted the cell sizes are significantly smaller than I would normally recommend for a pool. The amp draws simply aren't sufficent to get a decent residual.


Return to “Pool Surface Staining & Discolored Pool Water”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 4 guests