Aqua Rite clouds

SWGs, salt water chlorine generators, chlorinators,
ozone generators, UV systems, . . .
Jeff Pennington
Pool Newbie
Pool Newbie
Posts: 3
Joined: Sat 09 Jun, 2007 15:57

Aqua Rite clouds

Postby Jeff Pennington » Sun 10 Jun, 2007 11:26

I just installed an Aqua rite this summer. Whenever the unit is on and generating, the jets all have very cloudy water coming out of them. This, I think causes the entire pool to cloud up. The cell is clean- No scale at all. I have also had bad algae problems for the first time this summer. I dont know if the two issues are related but any help and advise is appreciated.


Jeff Pennington
Pool Newbie
Pool Newbie
Posts: 3
Joined: Sat 09 Jun, 2007 15:57

Further Info

Postby Jeff Pennington » Sun 10 Jun, 2007 11:33

BTW- All chemical levels seem to be in the range reccommended by Aqua Rite. I just dont get it. I hope someone has encountered this issue. Otherwise, I am starting to think I made a bad investment. Thanks in advance.
Buggsw
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 421
Joined: Sun 13 May, 2007 23:26

Postby Buggsw » Sun 10 Jun, 2007 16:17

It's possibly bacteria in your water. The aqua rite is one of the best SWG's out there.

If you've had algae problems, you may not be shocking high enough and for long enough to rid the bacteria. The cloudiness may just be dead algae.

Also, your pH could be high. Lower it to 7.2 until it clears.

Run your pump 7/24. It should clear within the week.
Jeff Pennington
Pool Newbie
Pool Newbie
Posts: 3
Joined: Sat 09 Jun, 2007 15:57

Bacteria?

Postby Jeff Pennington » Mon 11 Jun, 2007 10:15

I guess it could be dead bacteria, but I flush the filter alot. So I would think that I flush away the dead bacteria. This has been going on for weeks. PH = 7.2
filter leaking?

Pool Cloudy

Postby filter leaking? » Tue 19 Jun, 2007 09:03

What type of filter do you have? Do you have any residue on the bottom of the pool? You could have a hold/crack/bad seal in your filter.
Gabe

Postby Gabe » Mon 30 Jul, 2007 11:48

I have a pool with the EXACT same problem, EXACT SWG. Filter is a Hayward cartridge.

When the SWG runs, it creates cloudy water directly from the return lines. Turn the SWG off and the water is clear. Turn the SWG on again and the cloudyness starts again. Sometimes with foam floating on the surface.

I tested the chemicals and here's what I got on the first reading since it started

Cl 1.5
Ph 7.6
Alk 40
Water hardness read pretty high
Conditioner read low

So I corrected some of the problems, brought the alk back up to 90, added conditioner and over a span of two days, no change. SWG still creates cloudy water.
Mrmatt

re: cloudy water

Postby Mrmatt » Tue 14 Aug, 2007 14:01

Do any of you use a metal sequestreant? I've seen simular results in normal pools. When adding liquid chlorine, the pool will literally cloud up before your eyes. This is appearntly caused by high sequest. Try regulating the amount of sequest you're using. I've also found that a cup of acid/10k gals. usually neutralizes this cloudy reaction.

Return to “Salt Water Chlorine Generators, Ozone, UV”

Who is online at the Pool Help Forum

Users browsing this forum: Bing. [bot] and 0 guests