DE Filter Troubleshooting

Discussions that do not fit into any of the
swimming pool categories and general topics.
PoolRobR
Pool Newbie
Pool Newbie
Posts: 9
Joined: Wed 23 May, 2007 15:06

DE Filter Troubleshooting

Postby PoolRobR » Sun 10 Jun, 2007 15:48

Hi All,

Can anyone offer a troubleshooting guide for DE filters? For instance, what are the symptoms of too much powder? Too little powder? What should the filter pressure be? And so on.

Here's my situation. I've got a Hayward Perflex EC65 DE filter, and a Hayward 3/4 hp SuperPump. If I turn the pump on in the morning, by late afternoon I've got no flow through the filter. If I bump the filter (regenerate, I think they call it), I can get several more hours of good flow. So I think the filter needs a new batch of powder, so I follow the instructions and backflush all (or most) of the powder, then add some more powder to the skimmer. The exact same thing happens, no flow after several hours. Bear in mind the water is crystal clear during all this time.

So, I disassemble the filter, completely clean the filter housing and the fingers. This thing is like new at this point. Ressemble, add the recommended amount of DE powder, and within 6 hours or so, the flow is once again negligible. The pressure when freshly assembled is about 23 pounds, and when the flow stops a few hours later the pressure is 25-26 pounds.

I'm at a loss. Any ideas?

Rob


Walter
Swimming Pool Pro
Swimming Pool Pro
Posts: 167
Joined: Fri 07 Jul, 2006 08:11
Location: Mount Pleasant, South Carolina

Postby Walter » Mon 11 Jun, 2007 07:59

Sure your putting the right amount of DE in?
We are a custom pool and spa builder. We can only offer suggestions with the information given. Don't hesitate to email me if you have a questions and I will answer it as best as I can or point you in the right direction.
powenmurphy
Pool Newbie
Pool Newbie
Posts: 3
Joined: Sat 09 Jun, 2007 11:01

Postby powenmurphy » Mon 11 Jun, 2007 08:47

I am exactly in the same boat as you...exactly!!!!!!

I found my problem was not enough DE and getting the system primed correctly. Good circulation all day long.

My problem now is...how can i keep suction up when trying to vaccum???
Greg

DE filter

Postby Greg » Mon 18 Jun, 2007 21:53

HAD SIMILAR PROBLEMS IN PAST, MIGHT WANT TO TRY AN ACID WASH
AVAILABLE AT MOST POOL STORES. YOU SIMPLY TAKE FILTER APART, SOAK FINGERS IN A DILUTED SOLUTION OVERNIGHT. REMOVES BODY AND SUNTAN OILS ETC... WORKED FOR ME
GOOD LUCK

Return to “Poolside - General Discussions”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests