Pump Does not Fully Prime

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
aedpool
I'm new here
I'm new here
Posts: 1
Joined: Fri 31 Jul, 2020 14:35
My Pool: In-Ground

Pump Does not Fully Prime

Postby aedpool » Fri 31 Jul, 2020 15:03

Hi,
We have a new Magnum Force 3/4 HP Pump, and have been having issues on and off with getting it to be fully primed. We had been having similar issues with our old pump before we replaced it. It will prime to about 1-2" below the top of the pump basket lid. In the few months we have eventually been able to get it running at full prime and it will work perfectly for a couple weeks and hold its prime over night. Then when we have to clean the basket, and re-prime it, it often takes many attempts and backflushes before it will fully prime. This time, however we have tried for two days, cleaned and lubricated the o-ring, and cannot get it more than 80% primed. We've inspected all of the suction side fittings and the pump basket o-ring and can't see any leaks, and the fact that this has happened before but then we get it running and it ends up maintaining its prime perfectly in between cleanings, leads me to believe it might not be a leak. After the intitial start up, there are no bubbles that come out of the outlet jets. Is the pump potentially undersized? Any ideas would be appreciated!


Denniswiseman
Pool Industry Leader
Pool Industry Leader
Posts: 1761
Joined: Tue 06 Sep, 2011 05:48
My Pool: 10k inground fibreglass, Telescopic Cover, Hayward Powerline pump, Quality filter with glass media, 27kw output heat pump, K-2006C test kit
Location: United Kingdom

Re: Pump Does not Fully Prime

Postby Denniswiseman » Sat 01 Aug, 2020 03:06

An undersized pump won't stop priming
Fit a non return valve to the pump inlet side, this will stop the water going back to the pool and all you need to do is top up the pump basket when cleaning

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: Yandex [Bot] and 0 guests