Low Pressure

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
jrs7

Low Pressure

Postby jrs7 » Mon 21 May, 2012 09:47

when pump runs on filter i get very little pressure but if i run it on recirculate pressure is much better but still not where it should be. no blockages in baskets or impeller and no air leaks.any ideas?


jwhop3
Pool Newbie
Pool Newbie
Posts: 3
Joined: Wed 30 May, 2012 11:43
My Pool: Foxx Inground Lagoon 14,000 gallons
PacFab Meteor Filter
Frog Inline Chlorinator
Location: VA

Low Pressure

Postby jwhop3 » Wed 30 May, 2012 12:22

I had the same as many above me - pine seeds in the pump, stuck in the vents of the pump flywheel reducing flow of water to filter.
jwhop3
Pool Newbie
Pool Newbie
Posts: 3
Joined: Wed 30 May, 2012 11:43
My Pool: Foxx Inground Lagoon 14,000 gallons
PacFab Meteor Filter
Frog Inline Chlorinator
Location: VA

Low Pressure

Postby jwhop3 » Wed 30 May, 2012 12:30

jrs7 wrote:when pump runs on filter i get very little pressure but if i run it on recirculate pressure is much better but still not where it should be. no blockages in baskets or impeller and no air leaks.any ideas?


Check your filter for a broken lateral. Do you find sand in the bottom of the pool, or bubbles coming out of the return jets?
DonnaS

Low Pressure

Postby DonnaS » Tue 19 Jun, 2012 08:12

Hello - anyone got any idea's - just opened my pool water being pulled in fine to the pump, my pump was just overhauled - however not getting any PSI at all???
Guest

Low Pressure

Postby Guest » Wed 04 Jul, 2012 11:45

:thumbup: THANKS! I was reluctant to try the impeller...but jumped in with both feet...its exactly what it was...CLOGGED with a stick and very small leaves...cleaned, lubed,and back together, and my pressure is back to 15! THANKS for this forum...I literally thought my pump had gone bad...which would have been at least a $250.00 fix...THANKS again! :D
mexicanadave

normalPressure

Postby mexicanadave » Thu 05 Jul, 2012 17:20

What is a normal range for pump pressure? Mine is running at 18-20psi.
macstrange

Low Pressure

Postby macstrange » Sun 22 Jul, 2012 17:45

Had to repair a leak in impeller housing. Removed pump and impeller, made repair, cleaned sufaces and assembled with Permatex blue RTV silicone gasket maker. I'm getting a low pressure reading and my Kreepy Crawley quits shortly after turning the filter on. I also hear air in the sand filter. I don't see any apparent leaks. What should I look for?
CGPoolman
Swimming Pool Pro
Swimming Pool Pro
Posts: 168
Joined: Sat 28 Apr, 2012 17:52
Location: Orlando FL

Low Pressure

Postby CGPoolman » Mon 23 Jul, 2012 08:49

Macstrange,

If everything was good before you took the pump apart - start there. Do you see air in the strainer pot or does the pump have a full prime? Make sure the impeller is screwed all the way down on the shaft, and that it is not rubbing or binding up against anything. Check that the motor seal is installed correctly. Check for any clogs/obstructions in the pump that could be slowing down your flow.

CG
bubbamoop

Low Pressure

Postby bubbamoop » Wed 25 Jul, 2012 09:10

Great great tip. I pulled out my basket and pulled out a bunch of hemlock needles, etc. Thanks for saving me stress and money! So easy! :D
Socalchris

Low Pressure

Postby Socalchris » Sat 25 Aug, 2012 20:21

reviewed a lot of the posts. Check the propeller, moving freely. Forced water pack through the filter just to see if something was clooged but could not really tell. Still at about 13 psi. Can't get enough pressure to run ther sweep or circulate the water enough to keep it clean. Any suggestions???

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests