Pump making horrible noise

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.

Pump making horrible noise

Postby ICEE » Tue 04 Sep, 2007 20:27

About 2 weeks ago our care taker blew its lid off and we had to wait for a replacement to get ordered. The pump was shut down as soon as it happened and sounded perfectly fine. Today the part finally came in and when we turned the pump on it it making this awful sound like metal or something. It is filtering fine but this noise it just ridiculous. There is no way we can run the pump at night and we need to because our pool is a lagoon. It is an in ground pool if that matters, but any ideas why the pump would sound like this after its been off for about 2 weeks and it was fine when originally shut down? Something has to be done quick. Thanks


Postby Guest » Fri 07 Sep, 2007 01:11

no one has insight? Did i put this in the wrong forum by chance
User avatar
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 398
Joined: Thu 16 Aug, 2007 14:32
Location: So Cal

Postby mr_clean » Fri 07 Sep, 2007 09:22

Have you put your ear down to pump/motor and listened to where noise is coming from, Motor or pump? If you think it's the motor, how old is it?
If no warranty left, you can have someone possibly fix with a normal no-warranty to it or buy new motor with 1yr warranty.

Postby ICEE » Fri 07 Sep, 2007 14:48

Truthfully I'm not sure how old the motor is, we rent so I guess I need to contact the house owner but he's not going to be happy because every time we need to call him its so he can replace something. The filter already had to get replaced along with the piping. People say its the bearings when I describe to them whats going on but the odd thing is it doesn't sound like metal on metal. Almost like something is hitting something as the impeller turns but I checked that and its not caught on anything. You can also almost here what sounds like a lot of AIR being dispersed as its on. Its working fine though and the pool jets are pumping out great just this dang pump is screaming loud now where it use to be quiet 2 weeks ago when we shut it down. I don't know what could of really changed in 2 weeks with the pump off that would cause it to respond like this now once turned back on.

Postby Lteisseyre » Mon 05 May, 2008 00:28


If you still have noise issues, I have a new product (patent pending) that is the solution to your noise problem. It will reduce noise by 75-90%

I can be contacted at info(at)premierinnov(dot)com and I will email you a brochure or visit www(dot)premierinnov(dot)com



Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 2 guests