water

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
monkeynowater

water

Postby monkeynowater » Sun 04 Nov, 2007 10:48

I don't see the water return to pool from the ports. what do i do?


User avatar
mr_clean
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 398
Joined: Thu 16 Aug, 2007 14:32
Location: So Cal

Postby mr_clean » Sun 04 Nov, 2007 11:07

I don't see the water return to pool from the ports. what do i do?


Have you cleaned pump basket/skimmer basket?
Can you see in pump through lid? Is there water in pump?
Take off lid add water & restart pump to prime.
monkeynowater

water

Postby monkeynowater » Sun 04 Nov, 2007 15:15

mr_clean wrote:
I don't see the water return to pool from the ports. what do i do?


Have you cleaned pump basket/skimmer basket?
Can you see in pump through lid? Is there water in pump?
Take off lid add water & restart pump to prime.


Yes, I cleaned the basket, there are water but at low flow, I also changed the gasket, backwashed too, still have problem.
User avatar
mr_clean
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 398
Joined: Thu 16 Aug, 2007 14:32
Location: So Cal

Postby mr_clean » Sun 04 Nov, 2007 18:08

Yes, I cleaned the basket, there are water but at low flow, I also changed the gasket, backwashed too, still have problem.


Did you check pump lid's Oring? make sure its on & lubed so theres no air getting in system. Is there any air bubbles coming from return lines?
what does filter pressure read?

If you have low pressure but water still is circulating slow your impeller could be clogged with debris or you have clog between skimmer & pump.

you can check impeller by taking off pump lid taking out basket. Theres a small hole at bottom where water gets suctioned. Take your finger or small screw-driver & turn impeller & feel for debris. It shouldturn very easy without a problem.

If there is no debris & impeller seems good then take a small sandwich bag and sense you get slow water flow let the skimmer suck it in & it should go to pump in basket if theres no clog. If it does not go to basket, take off pump lid remove basket & you can take garden hose with a drain king on the end and insert into pipe that goes to skimmer. This will build pressure and send any clog back out to skimmer. You can also just try with garden hose with old shirt wrapped around it so water going to skimmer does not loose pressure or air compressor with air nozzle to blow air.

If both do not work then you would need to remove motor from back of pump to check impeller further as debris could be inside stuck.
monkeynowater

water

Postby monkeynowater » Sun 04 Nov, 2007 19:26

mr_clean wrote:
Yes, I cleaned the basket, there are water but at low flow, I also changed the gasket, backwashed too, still have problem.


Did you check pump lid's Oring? make sure its on & lubed so theres no air getting in system. Is there any air bubbles coming from return lines?
what does filter pressure read?

If you have low pressure but water still is circulating slow your impeller could be clogged with debris or you have clog between skimmer & pump.

you can check impeller by taking off pump lid taking out basket. Theres a small hole at bottom where water gets suctioned. Take your finger or small screw-driver & turn impeller & feel for debris. It shouldturn very easy without a problem.

If there is no debris & impeller seems good then take a small sandwich bag and sense you get slow water flow let the skimmer suck it in & it should go to pump in basket if theres no clog. If it does not go to basket, take off pump lid remove basket & you can take garden hose with a drain king on the end and insert into pipe that goes to skimmer. This will build pressure and send any clog back out to skimmer. You can also just try with garden hose with old shirt wrapped around it so water going to skimmer does not loose pressure or air compressor with air nozzle to blow air.

If both do not work then you would need to remove motor from back of pump to check impeller further as debris could be inside stuck.


Thanks. i changed O-ring couple days ago, I was able to use my finger to turn the impeller though it's not totally free, maybe it's too far that I can't realy touch the impeller. I'll try the sandwich bag, garden host to flush, then the taking off pump to check the impeller. I'll let you know what happen after that. By the way, I don't see water come out in return line so not bubles, what could that be? Oh, the filter pressure reads about 22-23.
monkeynowater

filter

Postby monkeynowater » Mon 05 Nov, 2007 13:58

Great thanks for the help. I finally find the problem, it's the filter needs to clean. Now more, I have DE filter, how do I take it apart and clean it?

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests