Pump & Filter Problems!!

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
Pool Newbie
Pool Newbie
Posts: 1
Joined: Mon 28 Apr, 2008 10:03

Pump & Filter Problems!!

Postby stephan » Mon 28 Apr, 2008 10:26

I have a 16' x 32' (512 sq.ft.) inground pool with a Pool Capacity of 21,120 Gallons. I have a Hayward Super Pump (1.5 HP 115/230 volts for 1.5" PVC piping) & a Hayward DE Filter 3620 (36 Sq.Ft. DE Filter). When turned on & the filter is clean, the filter’s PSI is always at 20psi (should be 10psi) Pump works, jets work, returns work well for about 2 hours with strong water flow, suction and strong water seen churning through glass cover on the pump, but then the jets die down to very slow, the suction in returns dies out and much less water seen in glass cover on pump (straining). (Filter stays at 20 psi the whole time) If I backwash, the glass tube shows that the filter is clear and when I turn handle back to filter and run again, the pool works great and then again after about 2 hours it slows down considerably and suction dies out. Can anyone please help a very frustrated and exhausted pool owner???
Is the pump too powerful, wrong filter? Any suggestions or help would be greatly appreciated!!!! Thank you for your time and consideration.

Swimming Pool Superstar
Swimming Pool Superstar
Posts: 257
Joined: Tue 29 Apr, 2008 17:14

Postby Denali » Tue 29 Apr, 2008 17:50

Hi Stephan,

You said your PSI should be 10. Is that the pressure it once ran at?

When you backwash, the pressure should return close to the clean pressure. If it doesn't then you probably need to take the filter apart and clean it out. Dirt builds up over time even with backwashing.

If the filter runs at 20 PSI and the flow is strong and then the flow slows down but is still at 20, the pressure gauge may need replacing.

A 36 sq. ft. filter is a bit small but will do the job. It will require more frequent cleanings.

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests