Vaccuuming question...

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts

Vaccuuming question...

Postby MiamiSun » Mon 01 May, 2006 12:22

I am a new pool owner and have a a question about vaccuuming. We have a spa that connects and flows into the pool, and when vaccuuming, the stuff sucked up from the pool is blown back in through the jets. I can see tidbits of green algae shooting back into the pool from the jets. The vaccuum is still cleaning the pool and the filters and basket are clean, but more chemicals are being required because of this. What should I do?

Pool Helper

Pool filter problem

Postby Pool Helper » Mon 01 May, 2006 18:00

Sounds like you have an issue with your filter. The filter should trap these particles but it is letting them through.

You may need to check your filter and change or add some filter medium. What kind of pool filter do you have?

Postby MiamiSun » Sat 06 May, 2006 16:25

We have an older filter system - American Commander - and cannot afford at the present time to replace the system. The filters themselves are in fairly new condition. I did notice that the cartridge cuppler is missing and when I contacted our local pool supply store, they called the manufacturer and found out that the model we need was discontinued in '97. They also said that the cuppler was not necessary for every day function and to not worry about it right away. Are they wrong?
Pool Newbie
Pool Newbie
Posts: 3
Joined: Mon 08 May, 2006 23:05

Postby PlumbEvil » Mon 08 May, 2006 23:28

try vacumning to "waste" if you have a multiport valve for the heavy loads. Sounds like you have an issue with your filter media. What kind of filter?

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: oBot [bot] and 0 guests