Please Help Me

Discussions that do not fit into any of the
swimming pool categories and general topics.
cashnighter
Pool Enthusiast
Pool Enthusiast
Posts: 10
Joined: Mon 12 May, 2008 21:19
Location: Katy,TX

Please Help Me

Postby cashnighter » Mon 12 May, 2008 21:44

Ill start off by introducing myself. My name is Steve and I live in Katy TX, I’ve been in charge of our family pool for about 4 years now. And it has always been pain but that was just because its a lot of work. But about 2 years ago it started acting weird. That’s when the DE started to leak back into the pool. Me being a rookie I dint know what to do so I when to my local pool supply store to ask some questions. I was told my filters were no good so I bought new ones after I installed them it seemed to be working well but like 20 minutes later I saw that dreaded white cloud coming out of the jets again and that’s what keep happening. I would be vacuuming it and it would be working find then all of a sudden all the algae I had vacuumed started to come out threw the jets It was very frustrating. I went back and bought some replacements for parts that seemed worn out. But still the problem persisted. I don’t trust my local pool store any more they got around 500 dollar out of my wallet and still the problem isn’t solved. Its been 2 years since my family took a swim in our pool. I’m desperate and every one in my family is pissed off at me for not doing my duty.

So I come to this forum in search of advice from all you experienced people. Who hopefully can help get my pool running for the summer


I Didn’t Know it would be such a pain
Pooltech32
Swimming Pool Wizard
Swimming Pool Wizard
Posts: 75
Joined: Thu 06 Jul, 2006 20:43

Postby Pooltech32 » Wed 14 May, 2008 00:18

what kind of filter do you have? Sand,Cartridge? filters can only handle so much sediment before they start dumping it back to the pool, I would suggest filling the pool right up and vaccuming to waste a couple of days in a row. that should get rid of the dust and algea.
Pool repair guy
Guest

Postby Guest » Wed 14 May, 2008 02:20

I have a DE filter. Sometimes it dumps the DE back into the pool right after I put it in. I know I don’t add to much because one day I even took a scale outside and weight the amount of de to match the manufactures recommended amount.
cashnighter
Pool Enthusiast
Pool Enthusiast
Posts: 10
Joined: Mon 12 May, 2008 21:19
Location: Katy,TX

Postby cashnighter » Sat 24 May, 2008 09:46

I have a DE filter and I just cleaned it out. At the moment its not leaking de but now I cant get any pressure.

I stared to use the bleach and the water is blue I dont think there any more algea at the bottom but I wouldnt know since I cant see the bottom. The water is so darn cloudy I can hardly see the second step.
I Didn’t Know it would be such a pain

Return to “Poolside - General Discussions”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests