2 returns not working pressure too high

Leaks in the pool, plumbing, filtration system, skimmer, ...
Finding & repairing swimming pool leaks.
Pool Newbie
Pool Newbie
Posts: 1
Joined: Tue 13 May, 2008 01:35

2 returns not working pressure too high

Postby ewek » Tue 13 May, 2008 01:47

"My pool pump runs and when I run it thru the spa the water is spinning in the catch. However when I run it to my pool it feels as though its getting about 25lbs of suction thats what the gauge is showing and it will suck up your hand, but when I attach the skimmer it runs for a few seconds and stops. I can't hand vacumm even though it feels like im getting a lot of suction at the pool wall. I have detached the skimmer and noticed that the in ground catch to the pool is not drawing any suction or water and 2 returns out of 5 on the far side of the pool are not working (Blowing water)despite the gauge shows 25lbs and it feels as though it's sucking great. That is too much pressure it normally ran about 20 psi. I am getting really frustated with this, because eventually it loses its prime all together. I recently drained and refilled and cleaned my tile I and even put drain opener in while it was empty and washed it out, I don't know what the problem is, I am not seeing any visable leaks. This is an inground with spa attached 75,000 gallon

pool it is very large. I don't want to have to drain it again. Please help

Swimming Pool Superstar
Swimming Pool Superstar
Posts: 332
Joined: Fri 07 Mar, 2008 20:56
Location: Maryland

Postby muss08 » Tue 13 May, 2008 06:40

Sounds like you have a suction side leak. If you are losing your prime then you are drawing in air somewhere. Could be underground. What do you mean you detached your skimmer? When was the last time you backwashed?
APSP Certified Service Pro
Jandy Tech School
Pentair Tech Training
Raypak Heater School
5 yrs experience

Return to “Swimming Pool Leaks”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests