my pool is not cleaning

Adding chemicals, vacuuming, backwashing,
brushing, filter care, filter cleaning, replacing
worn or broken pool parts
1jlaudio

my pool is not cleaning

Postby 1jlaudio » Wed 28 May, 2008 18:40

I have a problem with my pool. I clean my pool with the vacum for a few minutes and it looks like it's working but then all of a sudden the dirty water comes back throgh the holes. I dont' know what to do about it. can someone help me solve this problem please?


muss08
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 332
Joined: Fri 07 Mar, 2008 20:56
Location: Maryland

Postby muss08 » Wed 28 May, 2008 20:37

What kind of filter do you have? Sand, cartridge, DE?
APSP Certified Service Pro
Jandy Tech School
Pentair Tech Training
Raypak Heater School
5 yrs experience
blu

me 2

Postby blu » Sat 31 May, 2008 15:18

same problem here
I have a cartridge DE filter....

heeeeeeeeeeeeeeeelp
its an above ground 18x33
professorjkc

Me Three

Postby professorjkc » Sat 31 May, 2008 17:30

I also am getting dirty water back into the pool, sand filter with new sand, inner guts all in great shape. Only shoots dirt while vacuuming.
Do I just clean it on backwash?
Guest

Postby Guest » Sat 31 May, 2008 22:17

When dirt is coming back into the pool there is something wrong inside the filter or perhaps with the valve that controls backwashing.

For a sand filter you want to check the laterals inside the filter.

For DE and cartridge filters you want to look for holes or tears in the grids.

Return to “Routine Pool Cleaning & Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests