Filter Lines Will Not Stay On Please Help!!

The basics of swimming pool maintenance.
New swimming pool owner's questions.
Help getting started with daily pool care.
hbk4041
Pool Newbie
Pool Newbie
Posts: 2
Joined: Sun 03 Aug, 2008 08:15

Filter Lines Will Not Stay On Please Help!!

Postby hbk4041 » Sun 03 Aug, 2008 08:53

Hi, I am not really a new owner of pools I have had one just about all my life. Three years ago I got my own pool when I bought my house, before it was always my parents.

A little history first, I have had this pool for the last three years I have had trouble keeping it cleen and clear every year. Last year was the best year we got a new cartrige filter for our filter. This gave me the best results I was cleaning the cartrige out about every two weeks. Other then the grean when we opened it and some cloudyness it was clear all year.

This year we have had nothing but problems. When we opened it we cleaned it like always. Added all the same cemicals as last year and followed the same process. About a week after we started one the hose from the filter to the jet got a hole in it. I patched it quickly which lasted for a few days but then completely broke. I pulled an old hose out and with some duct tape and clamps made it fit. This lasted for a few days but then my current problem developed.

This make shift hose replecement the filter started blowing off the hose. I thought it was becasue the hose was not the correct hose and size but when I got the correct hose and new clams I still have the some problem. I am out of ideas with what I can do. I have been fighting with this problem for weeks. I hose will even come off when the filter isn't even turned on. The one thing I haven't checked it the pressure gauge just stopped working about the same time this problem started. When the hose is on for the short time the just is way more powerfull then normal. Could this be my hole problem? If it is how do you explain how the hose falls off when my filter isn't even on or hasn't been on after I reattach it? This problem is on a 24 foot round 4 foot deep above ground pool.

Please help I would like to use my pool atleast twice this year!!

Thanks and sorry for the long post

Brad :(

P.S. I also posted this in the Pool Pumps, Plumbing & Pipeing section so don't think your going crazy.


Return to “Basics for New Pool Owners”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests