unable to maintain prime on the pump

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
shirley

unable to maintain prime on the pump

Postby shirley » Wed 13 Aug, 2008 15:16

We developed a large crack at the bottom of the skimmer and have just finished replacing the skimmer. There are no apparent leaks now. However, even though the pump is full when I turn it on (opening the lid and allowing it to flow in), it quickly loses prime. The pump continues to draw some water but no pressure is generated in the sand filter and the pump will not fill. I'm sure I missed a step - just don't know what that is. Can you help?


Guest

Re: unable to maintain prime on the pump

Postby Guest » Thu 14 Aug, 2008 02:47

First place I would look is the pump lid. Make sure the oring is in place and air isn't being pulled in there.

If you are able to shut off the flow from the skimmer and only draw from the main drain, you can see if the problem is at the skimmer. If you don't have a main drain or can't isolate it you can't try that of course.

shirley wrote:We developed a large crack at the bottom of the skimmer and have just finished replacing the skimmer. There are no apparent leaks now. However, even though the pump is full when I turn it on (opening the lid and allowing it to flow in), it quickly loses prime. The pump continues to draw some water but no pressure is generated in the sand filter and the pump will not fill. I'm sure I missed a step - just don't know what that is. Can you help?

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests