What is floc, clarifier, stabilizer, cyanuric acid,
algaecide, brightener, dichlor, sodium hypo,
sodium bisulfate, ....??


Postby Rubee » Mon 01 Dec, 2008 23:41

Hi, i have around a 30,000lt pool and are just in the process of getting it ready for summer! When i do the strip test the ph and alk levels are fine, but chlorine is non-existent after putting about 200gms in everyday as a shock dose and also have a floater with 2 tablets in it! The pool is still quite cloudy and ive been running my pump for around 120hours. What would you suggest i do now? Any help would be appreciated! Thanks!

chem geek
Pool Industry Leader
Pool Industry Leader
Posts: 2382
Joined: Thu 21 Jun, 2007 21:27
Location: San Rafael, California


Postby chem geek » Tue 02 Dec, 2008 00:18

Read this article in the Pool School at Trouble Free Pool. Most likely you have algae and that is consuming the chlorine. You should get a good test kit, either the Taylor K-2006 you can get at a good online price here or the TF100 kit from tftestkits(dot) com here with the latter kit having 36% more volume of reagents so actually less expensive "per test".

In particular, you should test your CYA level. If you've been using Trichlor pucks and don't have a lot of water dilution, the CYA level may be very high. That requires you to have a higher FC level or to use a supplemental algaecide (PolyQuat 60) or a phosphate remover to prevent algae.


Postby bambino » Fri 13 Mar, 2009 03:13

Hey Rubee

You gotta shock the pool over and over till the freechlorine stays over 3.0

After that the chlorine doesnt fall so quick and your tabs with a weekly shock should do the trick. :wink:

Return to “Pool Chemical Problems & Swimming Pool Chemicals”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests