Resolving inconsistent water flow caused by debris

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
bwillis
Pool Newbie
Pool Newbie
Posts: 2
Joined: Thu 19 Mar, 2009 12:09
My Pool: Inground vinyl liner; 17x33; max depth 8'; WhisperFlo 1.5hp pump approx 1 and 1/2 years old; sand filter (approx 325lb)

Resolving inconsistent water flow caused by debris

Postby bwillis » Thu 19 Mar, 2009 12:31

I have WhisperFlo 1 1/2 HP pump for my inground 17x33 vinyl liner pool. Everything was working great until yesterday when, in my haste, I turned the pump back on without putting the secondary (?) basket into the volute (hope I'm using these terms correctly while looking at a PDF manual). Leaves and other debris went straight into the impeller. I shut off the pump and put the basket in.

THE PROBLEM
However, now the water pressure SLOWLY builds...then, as soon as it hits 20psi, all water ABRUPTLY DROPS and pressure goes to ZERO...then it repeats this cycle about every 1-2 minutes.

My attempts at repair
1. I removed the 6 bolts connecting the "wet side"(where the basket sits) to the "side side"(motor). Cleaned debris out (as much as I could SEE). Re-connected the "wet" and "dry" sides, replacing the 6 bolts.

2. Thinking that it could possibly be something stuck in the filter valve gates (?..where you change from Filter to Backwash, Rinse, Etc), I took that off of the top of my filter (325lb sand filter). But, it was clear as could be.

Should I actually REMOVE the impeller from the SHAFT and try to clean it out? Or is it sufficient that I can spin the impeller by hand and don't visibly see any trash/debris?

Where else should I look?

thank you for any help/advice!

Barry Willis


greg340
Pool Enthusiast
Pool Enthusiast
Posts: 16
Joined: Sat 26 Apr, 2008 21:51
Location: nj

Resolving inconsistent water flow caused by debris

Postby greg340 » Thu 19 Mar, 2009 13:23

Remove the wet end again then remove the diffuser and clean each vain of the impeller. Just cleaning the center won't remove all the debris.
Twin State Pool Service
bwillis
Pool Newbie
Pool Newbie
Posts: 2
Joined: Thu 19 Mar, 2009 12:09
My Pool: Inground vinyl liner; 17x33; max depth 8'; WhisperFlo 1.5hp pump approx 1 and 1/2 years old; sand filter (approx 325lb)

Resolving inconsistent water flow caused by debris

Postby bwillis » Thu 19 Mar, 2009 14:05

thanks, Greg...that's what I try next..I'll let you know how it goes!!

Barry

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 1 guest