Pressure switch all the way out - still no contact

Electric heaters, gas heaters, heat pumps,
solar heaters, geothermal heating, solar pool
covers and wood-burning pool heating equipment.
hottubbra

Pressure switch all the way out - still no contact

Postby hottubbra » Sat 23 May, 2009 10:59

I have just installed a Raypak 337 LoNox Electronic Heater.
I have adjusted the pressure switch all the way out and it still wont close
I have closed the switch with a screwdriver and it fires properly.
The sand in the filter is new but the pump is about 5 feet above the pool 50 feet away.
The pump has a hard time priming by itself, but when it does, it does circulate OK.

I am a hot tub guy and I am putting this on my brother in laws pool. Never had too much problem with getting a pressure switch on a spa working, but this pool????????????

Also, the Raypak pressure switch has smaller threads than the regular 1/4" NPT. This means that most aftermarket pressure switches won't fit in .

Any thoughts on this......

thanks


Return to “Solar & Pool Heaters”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests