Algae problems in swimming pool water.
Green (cloudy) water or slimy pool walls.
Black algae. Mustard algae. Pink or white pool mold.


Postby guest » Fri 02 Jun, 2006 22:59

I had a loop loc cover on my pool (26,000 gallons)....biggest mistake I ever made. My pool opened very swampy and green. I have had the filter running 24 hours a day for the past week......God! my electric bill will be through the roof. I brought a water sample to the pool place. They told me my PH was low so I added enough to bring the PH up to normal levels. They told me to shock and use algecide. I have done both repeatedly and still can't even see the bottom of the pool....what should I do? I've alreay spent over $500 in chemicals. I'm at my wits end!!!


Help me

Postby lynz » Sat 03 Jun, 2006 10:55

We've had a similar problem, except our water was black when we opened it (3d year in a row we've had this problem)! After making sure your alkalinity and ph are balanced correctly, shock the water with chlorine shock. Also it helps to brush the side walls and bottom and then to vacuum up the debris in the bottom. You'll also have to diligently clean your filter (we've been doing this at least twice a day for the past week and will continue to do this until the problem goes away). If your problem is as bad as ours is, you might have to shock every day. So far the chlorine hasn't even registered on the test strip, even though we've shocked the water every day for the past 4 days. If you have a pool store near by, take them a pool sample and let them test it. I've been to ours everyday and each time I leave I say "See ya tomorrow". Incidently, our water is getting better each day. Today I would call it more blue than the blue green it was yesterday. The day before it was pea soup and the day before it was brown. Good luck!

Postby Guest » Sat 03 Jun, 2006 23:13

Thanks for the information. I will try that. I've dumped so much chemicals in and am starting to see some results. The filter has been running constantly and I have not shut it off. I will backwash as soon as the rain lets up. We've had heavy rain for the past 2 days I'm sure it has thrown my balance off now so I'll need to recheck it again. I'm learning as I go....the hard way. Do you dump algeacide and shock in your pool before you close it for the winter? Would that help along with opening the pool earlier in May instead of late May? The looploc cover lets in sunlight so the algae flourishes but if I do this would it help for next year?

Return to “Pool Algae & Green Pool Water”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 1 guest