Sand Filter and Superpump

Automatic pool cleaners, vacuum heads, pool covers,
decks, fencing, pool alarms and security ....
tomgaines
Pool Newbie
Pool Newbie
Posts: 3
Joined: Tue 14 Jul, 2009 07:46
My Pool: 20 x 40 inground vinyl liner heyward superpump
1 1/2 hp old triton filter
2 circulators on returns
Location: SC

Sand Filter and Superpump

Postby tomgaines » Wed 15 Jul, 2009 11:56

I have a 20 x 40 inground with a triton sand filter and 1 1/2 hp Heyward Superpump. I have recently developed a mustard algae problem. My problem is that when I vacuum to waste and then return to filter, It blows the algae back into the pool from the returns. My Sand filter is over 20 years old. Could this be the problem or is there something else going on? Help...


campo

Sand Filter and Superpump

Postby campo » Wed 15 Jul, 2009 13:13

have you changed your sand in the last 5 years?
tomgaines
Pool Newbie
Pool Newbie
Posts: 3
Joined: Tue 14 Jul, 2009 07:46
My Pool: 20 x 40 inground vinyl liner heyward superpump
1 1/2 hp old triton filter
2 circulators on returns
Location: SC

Sand Filter and Superpump

Postby tomgaines » Wed 15 Jul, 2009 15:10

Yes, changed it last summer when I replaced the liner.
Denali
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 257
Joined: Tue 29 Apr, 2008 17:14

Sand Filter and Superpump

Postby Denali » Thu 16 Jul, 2009 02:58

tomgaines wrote:I have a 20 x 40 inground with a triton sand filter and 1 1/2 hp Heyward Superpump. I have recently developed a mustard algae problem. My problem is that when I vacuum to waste and then return to filter, It blows the algae back into the pool from the returns. My Sand filter is over 20 years old. Could this be the problem or is there something else going on? Help...


Hi,

Try running the system on the rinse setting briefly before returning it to filter. Vacuuming to waste bypasses the filter so it shouldn't be causing anything.
tomgaines
Pool Newbie
Pool Newbie
Posts: 3
Joined: Tue 14 Jul, 2009 07:46
My Pool: 20 x 40 inground vinyl liner heyward superpump
1 1/2 hp old triton filter
2 circulators on returns
Location: SC

Sand Filter and Superpump

Postby tomgaines » Fri 17 Jul, 2009 09:44

Agree, that's why I thought that one of the parts in the filtering system was not working properly.

Return to “Pool Equipment & Other Pool Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests