Pump Priming Problems

Pool pumps, pool filters and the plumbing of
swimming pools. Sand filters, cartridge filters,
fabric filters and alternative filter media.
simmo1
Pool Newbie
Pool Newbie
Posts: 1
Joined: Tue 29 Sep, 2009 01:40
Location: Australia

Pump Priming Problems

Postby simmo1 » Tue 29 Sep, 2009 02:05

Hi,

Can anyone tell me why everytime i start my pump i have to prime it?

The problem i am having is that when i turn off my filter all of the water in the pump and lines all runs back out into the pool through the skimmer box. It has quite a bit off pressure behind it and dis lodges the cover over the top off the skimmer box.

What could the problem be?


Me...
Swimming Pool Superstar
Swimming Pool Superstar
Posts: 302
Joined: Thu 26 Feb, 2009 11:11

Pump Priming Problems

Postby Me... » Thu 01 Oct, 2009 09:59

Could be the equipment is much higher than the water level. More likely a restriction in the line after the pump somewhere, or a dirty filter. A one way check valve installed on the pump suction side should stop this.
User avatar
mas985
Swimming Pool Pro
Swimming Pool Pro
Posts: 199
Joined: Tue 08 Sep, 2009 10:40
Location: Pleasanton, CA, USA

Pump Priming Problems

Postby mas985 » Thu 01 Oct, 2009 22:09

A pump will not drain or lose prime unless air can enter from somewhere. It doesn't matter if the pad is higher than the pool or not. Air must enter from somewhere to lose prime. More than likely it is an air leak in the pump basket lid. Clean it and put some silicone base sealer on the o-ring. Also check the drain plugs and add some sealer.

Also, if you have an air leak, you should see air in the pump basket while the pump is running.
Mark
Hydraulics 101 ; Pump and Pool Spreadsheets ; Pump Ed 101
18'x36' 20k gallon plaster/gunite pool, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge Filter, Solar Panels, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater
User avatar
Pool Clown
Swimming Pool Wizard
Swimming Pool Wizard
Posts: 88
Joined: Thu 10 Sep, 2009 00:15
My Pool: Uses a Chlorine generator, not a Salt Water Generator (SWG).
Location: Silicon Valley, CA

Pump Priming Problems

Postby Pool Clown » Sat 03 Oct, 2009 00:07

Since your getting such a "whoosh" (industry term) of water back thru the skimmer, what is probably happening is that you have two problems.
1.You have an air leak of some kind. and
2. your filter is not bleeding off air that accumulates in the filter tank like it should.

edit: Your air leak may be such that the bleed tube cant bleed off /keep up with the amount of air entering the tank

With the pump running, bleed off all the air in the filter tank, then turn the pump off, and you shouldn't get any whoosh.
Find and resolve the air leak 1st, and then open the filter and clean the screen on the bleed tube, if needed, and you should be set.
Factory warranty service for Pentair, Jandy, Raypak, Polaris, and Paramount pool cleaning systems.

Return to “Pool Pumps, Filters, Plumbing & Piping”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 9 guests