Jandy transformer "blows" twice in two weeks

Automatic pool cleaners, vacuum heads, pool covers,
decks, fencing, pool alarms and security ....
jap
Pool Newbie
Pool Newbie
Posts: 2
Joined: Sun 16 May, 2010 10:38
My Pool: Fiberglass with Jandy aquapure saltwater chlorinator. Built in 2006.
Location: VA

Jandy transformer "blows" twice in two weeks

Postby jap » Sun 16 May, 2010 11:07

I have a jandy aquapure salt generator system form 2006. I started up my pool this year and soon received error codes 170 and 193. About a day later, the front screen went blank. Called a repairman (not the most knowledgeable i think) and he tested the system and said the transformer was bad. He replaced it, started it up, and it worked fine. I came home, found the plug to the cell off, and plugged it back in. In a few hours the codes appeared again, then the front screen went blank again. I have found the repair/testing manual and checked the 1 and 8 test port on the back board. It says it is suppost to have 75 VAC, I have 0. Each of the 12 wire leads coming off of the transformer have .5 VAC, with 120 VAC coming into each of the two wires going into the transformer (power going into transformer, but not coming out). Could it be that I am unlucky with having two transformers go, or it there any possible way that an electrical "surge" is "blowing" transformers? At almost $300 a pop, I am hesitant to put another transformer in there with what is happening. Any advice would be appreciated as electricity is not my strong suit.

Thanks,

Jimmy


Guest

Jandy transformer "blows" twice in two weeks

Postby Guest » Mon 07 Jun, 2010 17:18

Jimmy....stop being cheap....just buy a new 1400...rather
than keep throwing good $$ after bad. You can buy a whole
new one for $800 online; much better idea.
jap
Pool Newbie
Pool Newbie
Posts: 2
Joined: Sun 16 May, 2010 10:38
My Pool: Fiberglass with Jandy aquapure saltwater chlorinator. Built in 2006.
Location: VA

Jandy transformer "blows" twice in two weeks

Postby jap » Thu 10 Jun, 2010 08:53

Can't change my cheapness, but I can call Jandy and have them explain to me that the front board is bad and needs to be replaced. Apparently if bad it will create resistance so that the voltage coming out of the transformer gets "backed up" until it blows the transformer. Hope this helps someone else. Oh yea, it was free because it was still under warranty, 3 yr warranty, who would have thought!

Return to “Pool Equipment & Other Pool Maintenance”

Who is online at the Pool Help Forum

Users browsing this forum: No registered users and 0 guests